Immediate Decodability-字典树

Immediate Decodability


Problem Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

 


Input

Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

 


Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

 


Sample Input

 
 
01 10 0010 0000 9 01 10 010 0000 9

 


Sample Output

 
 
Set 1 is immediately decodable Set 2 is not immediately decodable

题意:比较前缀,如果有一个字符串是另一个字符串的前缀,则这组数据is not immediately decodable。每组数据以‘9’分隔。

在建立字典树的过程中比较前缀,如果一个字符串结束后,它仍有儿子或已标记过。则有共同前缀。


点击打开链接



#include<bits/stdc++.h>///Immediate Decodability
using namespace std;
const int maxn = 2;
struct Node          ///字典树节点定义
{
    int flag;
    Node *son[maxn];  ///2个儿子。
};
Node *newNode()
{
    Node *p=new Node;
    p->flag=0;
    p->son[0]=NULL;
    p->son[1]=NULL;
    return p;
}
int gettree(Node *root,char *s)  ///将单词s插入到字典树
{
    int i,l;
    l=strlen(s);
    Node *p = root;
    for(i=0;i<l;i++)
    {
        int k=s[i]-'0';
        if(p->flag==1)
        {
            return 0;
        }
        if(p->son[k]==NULL)
            p->son[k]=newNode();
        p=p->son[k];
    }
    if(p->son[0]==NULL&&p->son[1]==NULL&&p->flag==0)
    {
        p->flag=1;
        return 1;
    }
    else
        return 0;
}
void freedom(Node *p)
{
    if(p->son[0])freedom(p->son[0]);
    if(p->son[1])freedom(p->son[1]);
    delete p;
}
int main()
{
    int i,n=0,m=0;
    char s[20][20];
    Node *root;
    while(scanf("%s",s[n++])!=EOF)
    {
        if(s[n-1][0]!='9');
        else
        {
            n--;m++;
            root=newNode();
            for(i=0;i<n;i++)
            {
                int k=gettree(root,s[i]);
                if(k==0)break;
            }
            if(i==n)
                printf("Set %d is immediately decodable\n", m);
            else
                printf("Set %d is not immediately decodable\n", m);
            freedom(root);
            n = 0 ;
        }
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值