STL优先队列-HDU-1509Windows Message Queue

STL优先队列

在优先队列中,元素被赋予优先级,当访问元素时,具有最高级优先级的元素先被访问。即优先队列具有最高级先出的行为特征。

优先队列在头文件#include <queue>中;

其声明格式为:priority_queue <int> ans;//声明一个名为ans的整形的优先队列

基本操作有:

empty( )  //判断一个队列是否为空

pop( )  //删除队顶元素

push( )  //加入一个元素

size( )  //返回优先队列中拥有的元素个数

top( )  //返回优先队列的队顶元素


优先队列的时间复杂度为O(logn),n为队列中元素的个数,其存取都需要时间。


在默认的优先队列中,优先级最高的先出队。默认的int类型的优先队列中先出队的为队列中较大的数。

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
int tmp[100];
struct cmp1
{
     bool operator ()(int x, int y)
    {
        return x > y;//小的优先级高
    }
};
struct cmp2
{
    bool operator ()(const int x, const int y)
    {
        return tmp[x] > tmp[y]; 
        //tmp[]小的优先级高,由于可以在队外改变队内的值,
        //所以使用此方法达不到真正的优先,建议用结构体类型。
    }
};
struct node
{
    int x, y;
    friend bool operator < (node a, node b)
    {
        return a.x > b.x;//结构体中,x小的优先级高
    }
};

priority_queue<int>q1;
priority_queue<int, vector<int>, cmp1>q2;

Windows Message Queue




Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
 
 
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
 

Sample Output
 
 
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

题意:模拟消息队列,get获得数据,put 放入数据,第一个为字符串代表数据的名称,第二个值为数据值,第三个数为优先级,数越小,优先级越高。

#include<bits/stdc++.h>
using namespace std;
struct que
{
    char a[100];
    int value;
    int p;///优先级
    int f;///先后
    bool friend operator < (que a,que b){
		if (a.p == b.p)
		return a.f > b.f;
		return a.p > b.p;     //越大优先级越小
	}
}qq;
int main()
{
	char get[4];
	priority_queue<que> q;
	int k = 1;
	while (~scanf("%s",get)){
		if (get[0] == 'G'){
			if (q.empty()){
				printf("EMPTY QUEUE!\n");
			}
			else {
				qq = q.top();
				printf("%s %d\n",qq.a,qq.value);
				q.pop();
			}
		}
		else {
			scanf("%s %d %d",qq.a,&qq.value,&qq.p);
			qq.f = k;
			k++;
			q.push(qq);
		}
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧农业是一种结合了现代信息技术,包括物联网、大数据、云计算等,对农业生产过程进行智能化管理和监控的新模式。它通过各种传感器和设备采集农业生产中的关键数据,如大气、土壤和水质参数,以及生物生长状态等,实现远程诊断和精准调控。智慧农业的核心价值在于提高农业生产效率,保障食品安全,实现资源的可持续利用,并为农业产业的转型升级提供支持。 智慧农业的实现依赖于多个子系统,包括但不限于设施蔬菜精细化种植管理系统、农业技术资料库、数据采集系统、防伪防串货系统、食品安全与质量追溯系统、应急追溯系统、灾情疫情防控系统、农业工作管理系统、远程诊断系统、监控中心、环境监测系统、智能环境控制系统等。这些系统共同构成了一个综合的信息管理和服务平台,使得农业生产者能够基于数据做出更加科学的决策。 数据采集是智慧农业的基础。通过手工录入、传感器自动采集、移动端录入、条码/RFID扫描录入、拍照录入以及GPS和遥感技术等多种方式,智慧农业系统能够全面收集农业生产过程中的各种数据。这些数据不仅包括环境参数,还涵盖了生长状态、加工保存、检验检疫等环节,为农业生产提供了全面的数据支持。 智慧农业的应用前景广阔,它不仅能够提升农业生产的管理水平,还能够通过各种应用系统,如库房管理、无公害监控、物资管理、成本控制等,为农业生产者提供全面的服务。此外,智慧农业还能够支持政府监管,通过发病报告、投入品报告、死亡报告等,加强农业产品的安全管理和质量控制。 面对智慧农业的建设和发展,存在一些挑战,如投资成本高、生产过程标准化难度大、数据采集和监测的技术难题等。为了克服这些挑战,需要政府、企业和相关机构的共同努力,通过政策支持、技术创新和教育培训等手段,推动智慧农业的健康发展。智慧农业的建设需要明确建设目的,选择合适的系统模块,并制定合理的设备布署方案,以实现农业生产的智能化、精准化和高效化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值