PAT A1066. Root of AVL Tree (25)

1066. Root of AVL Tree (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print ythe root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88
思路分析:

建立平衡二叉树即可, 然后输出根节点。

题解:

#include <stdio.h>
#include <algorithm>
#define MAX 20
using namespace std;

struct Node
{
	int data, h;
	Node *left, *right;
};
int n, seq[MAX];

Node* newNode(int x)
{
	Node* root = new Node;
	root->data = x;
	root->h = 1;
	root->left = root->right = NULL;
	return root;
}

int geth(Node* root)
{
	if(root != NULL) return root->h;
	return 0;
}

void updateh(Node* root)
{
	root->h = max(geth(root->left), geth(root->right))+1;
}

int getbf(Node* root)
{
	return geth(root->left) - geth(root->right);
}

void L(Node* &root)
{
	Node* temp = root->right;
	root->right = temp->left;
	temp->left = root;
	updateh(root);
	updateh(temp);
	root = temp;
}

void R(Node* &root)
{
	Node* temp = root->left;
	root->left = temp->right;
	temp->right = root;
	updateh(root);
	updateh(temp);
	root = temp;
}

void insert(Node* &root, int x)
{
	if(root == NULL)
	{
		root = newNode(x);
		return;
	}
	if(x < root->data)
	{
		insert(root->left, x);
		updateh(root);
		if(getbf(root) == 2)
		{
			if(getbf(root->left) == 1) R(root);
			else if(getbf(root->left) == -1)
			{
				L(root->left);
				R(root);
			}
		}
	}
	else if(x > root->data)
	{
		insert(root->right, x);
		updateh(root);
		if(getbf(root) == -2)
		{
			if(getbf(root->right) == -1) L(root);
			else if(getbf(root->right) == 1)
			{
				R(root->right);
				L(root);
			}
		}
	}
}

Node* create()
{
	Node* root = NULL;
	for(int i = 0; i < n; i++)
	{
		insert(root, seq[i]);
	}
	return root;
}

int main()
{
	scanf("%d", &n);
	for(int i = 0; i < n; i++)
	{
		scanf("%d", &seq[i]);
	}
	Node* root = create();
	printf("%d", root->data);
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值