PAT A1081. Rational Sum

1081. Rational Sum (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
思路分析:

分数处理。

注意:分数结构体建立,分数化简,分数四则运算,分数输出。

题解:

#include <cstdio>
#include <algorithm>
using namespace std;
const int MAX = 100;
struct Fraction{
	long long up, down;
	Fraction(){
		up = 0;
		down = 1;
	}
}sum, seq[MAX];
int n;

long long gcd(long long a, long long b){
	if(b == 0) return a;
	else return gcd(b, a%b);
}

Fraction reduction(Fraction c){
	if(c.down < 0){
		c.down = -c.down,
		c.up = -c.up;
	}
	if(c.up == 0) c.down = 1;
	else{
		long long d = gcd(abs(c.up), c.down);
		c.up = c.up/d;
		c.down /= d;
	}
	return c;
}

Fraction add(Fraction a, Fraction b){
	Fraction c;
	c.up = a.up * b.down + b.up * a.down;
	c.down = a.down * b.down;
	return reduction(c);
}

void print(Fraction a){
	Fraction c = reduction(a);
	if(c.down == 1) printf("%lld", c.up);
	else if(abs(c.up) > c.down) printf("%lld %lld/%lld", c.up/c.down, abs(c.up)%c.down, c.down);
	else printf("%lld/%lld", c.up, c.down);
}

int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%lld/%lld", &seq[i].up, &seq[i].down);
		seq[i] = reduction(seq[i]);
		sum = add(sum, seq[i]);
	}
	print(sum);
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值