PAT A1096. Consecutive Factors (20)

1096. Consecutive Factors (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7
思路分析:

求连续的因子。从2开始挨个时,看以哪个开头的连续因子数量最多,一直到sqrt(n)为止,不要到n,会超时。

注意:

因为是到sqrt(n)为止,所以如果给的是素数,则max最后是0,要特判输出。或者在一开始就对素数特判也可以,前边打印素数表或直接判定n是否为素数都可以。

#include <cstdio>
#include <cmath>
int n, max = 0, num, m, index = 0;

int main(){
	scanf("%d", &n);
	int range = floor(sqrt(n));
	for(int i = 2; i <= range; i++){
		num = 0, m = n;
		int j = i;
		while(m % j == 0){
			m /= j;
			j++;
			num++;
		}
		if(num > max){
			max = num;
			index = i;
		}
	}
	if(max == 0) printf("1\n%d", n);
	else{
		printf("%d\n", max);
		for(int i = index; i < index+max; i++){
			printf("%d", i);
			if(i != index+max-1) printf("*");
		}
	}
	return 0;
} 




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值