A. Letter Combinations of a Phone Number

Given a string containing digits from 2-9 inclusive, return all possible letter combinations that the number could represent.

A mapping of digit to letters (just like on the telephone buttons) is given below. Note that 1 does not map to any letters.

Sample Input

23

Sample Output

ad
bd
cd
ae
be
ce
af
bf
cf

Hint

the above answer is in lexicographical order, please output in the same order!

我的做法:

import java.util.Scanner;

public class Main {
	public static void main(String [] args) throws Exception {
		Scanner sc = new Scanner(System.in); 
		String str = sc.nextLine();
		char[] arr = str.toCharArray();
		int n = arr.length;
		String [][]a = new String[n][5];
		int num[] = new int[n];
		for(int i=0;i<arr.length;i++){
			if(arr[i] == '2'){
				num[i] = 3;
				a[i][1]="a";
				a[i][2]="b";
				a[i][3]="c";
				a[i][4]="*";
			}
			if(arr[i] == '3'){
				num[i] = 3;
				a[i][1]="d";
				a[i][2]="e";
				a[i][3]="f";
				a[i][4]="*";
			}
			if(arr[i] == '4'){
				num[i] = 3;
				a[i][1]="g";
				a[i][2]="h";
				a[i][3]="i";
				a[i][4]="*";
			}
			if(arr[i] == '5'){
				num[i] = 3;
				a[i][1]="j";
				a[i][2]="k";
				a[i][3]="l";
				a[i][4]="*";
			}
			if(arr[i] == '6'){
				num[i] = 3;
				a[i][1]="m";
				a[i][2]="n";
				a[i][3]="o";
				a[i][4]="*";
			}
			if(arr[i] == '7'){
				num[i] = 4;
				a[i][1]="p";
				a[i][2]="q";
				a[i][3]="r";
				a[i][4]="s";
			}
			if(arr[i] == '8'){
				num[i] = 3;
				a[i][1]="t";
				a[i][2]="u";
				a[i][3]="v";
				a[i][4]="*";
			}
			if(arr[i] == '9'){
				num[i] = 4;
				a[i][1]="w";
				a[i][2]="x";
				a[i][3]="y";
				a[i][4]="z";
			}
		}
		int number = 1;
		for(int i=0;i<n;i++){
			number = number*num[i];
		}
		//System.out.println(number);
		String []out = new String[number];
		for(int i=0;i<number;i++){
			out[i] = "";
		}
		int m = 0;
		for(int i=0;i<number;i++){

			out[i] = out[i]+a[m][1]; 
			i++;
			out[i] = out[i]+a[m][2]; 
			i++;
			out[i] = out[i]+a[m][3];
			if(a[m][4]!="*"){
				i++;
				out[i] = a[m][4];
			}
		}
		m++;
		
		while(m<n){
			int k=1;
			for(int i=0;i<m;i++){
				if(arr[i]=='7'||arr[i]=='9'){
					k = k*4;
				}else {
					k = k*3;
				}
			    
			}
			//System.out.println(k);
			for(int i=0;i<number;){
				for(int j=0;j<k;j++){
					out[i] = out[i]+a[m][1]; 
					i++;
				}
				for(int j=0;j<k;j++){
					out[i] = out[i]+a[m][2]; 
					i++;
				}
				for(int j=0;j<k;j++){
					out[i] = out[i]+a[m][3]; 
					i++;
				}
				
				if(a[m][4]!="*"){
					for(int j=0;j<k;j++){
						out[i] = out[i]+a[m][4]; 
						i++;
					}
				}
			}
			m++;
		}
		for(int i=0;i<number;i++){
			System.out.println(out[i]);
		}		
	}
}

同学易浩的做法:

import java.util.Scanner;


public class Main{
	public static void main(String[] args){
		Scanner sc = new Scanner(System.in);
		String s = sc.nextLine();
		String[][] map = {{"a","b","c"},{"d","e","f"},{"g","h","i"},{"j","k","l"},{"m","n","o"},{"p","q","r","s"},{"t","u","v"},{"w","x","y","z"}};
		int [] index = new int[s.length()];
		for(int i=0;i<s.length();i++){
			index[i] = (s.charAt(i)-'0');
		}
		String[] result;
		if(index.length==1){
			result = map[index[0]-2];
		}
		else if(index.length==2){
			result = fun(map[index[0]-2],map[index[1]-2]);
		}
		else{
			int n = index.length;
			result = fun(map[index[n-2]-2],map[index[n-1]-2]);
			for(int i=index.length-3;i>=0;i--){
				String []tmp = map[index[i]-2];
				result = fun(tmp,result);
			}
		}
		for(int i=0;i<result.length;i++){
			System.out.println(result[i]);
		}

	}
	
	public static String[] fun(String[] tmp,String[] tmp1){
		String [] result = new String[tmp1.length*tmp.length];
		for(int i=0;i<tmp1.length;i++){
			for(int j=0;j<tmp.length;j++){
				result[i*tmp.length+j]= tmp[j]+tmp1[i];
			}
		}
		return result;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
(Telephone Number Word Generator) Standard telephone keypads contain the digits 0 through 9. The numbers 2 through 9 each have three letters associated with them, as is indicated by the following table: Many people find it difficult to memorize phone numbers, so they use the correspondence between digits and letters to develop seven-letter words that correspond to their phone numbers. For example, a person whose telephone number is 686-2377 might use the correspondence indi- cated in the above table to develop the seven-letter word “NUMBERS.” Businesses frequently attempt to get telephone numbers that are easy for their clients to remember. If a business can advertise a simple word for its customers to dial, then no doubt the business will receive a few more calls. Each seven-letter word corresponds to exactly one seven-digit telephone number. The restaurant wishing to increase its take-home business could surely do so with the number 825-3688 (i.e., “TAKEOUT”). Each seven-digit phone number corresponds to many separate seven-letter words. Unfortunately, most of these represent unrecognizable juxtaposi- tions of letters. It’s possible, however, that the owner of a barber shop would be pleased to know that the shop’s telephone number, 424-7288, corresponds to “HAIRCUT.” A veterinarian with the phone number 738-2273 would be happy to know that the number corresponds to “PETCARE.” Write a program that, given a seven-digit number, writes to a file every possible seven-letter word corresponding to that number. There are 2187 (3 to the seventh power) such words. Avoid phone numbers with the digits 0 and 1.
06-09

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值