UVa1339 古老的密码 Ancient Cipher

Description

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher.Substitution cipher changes all occurrences of each letter to some other letter.

Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes `Z' to `A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT".

Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation 〈2,1,5,4,3,7,6,10,9,8〉 to the message "VICTORIOUS" one gets the message "IVOTCIRSUO".

It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were rst encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP".

Archeologists have recently found the message engraved on a stone plate. At the rst glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input

Input le contains several test cases. Each of them consists of two lines. The rst line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the rst line. It also contains only capital letters of the English alphabet. The lengths of both lines of the input le are equal and do not exceed 100.

Output

For each test case, print one output line. Output 'YES' if the message on the rst line of the input file could be the result of encrypting the message on the second line, or 'NO' in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES

Sample Output

YES
NO
YES
YES
NO

解题思路

题目的基本思路是寻找字母映射(一对一),那么对于两个字符串我们可以分别统计出现的字母的次数,得到两个数组mes[26]和cip[26],然后排序进行比较即可。因为字母映射是一对一,只要排序后两个数组从大到小(或从小到大)的所有数值相同,那么必然存在一种字母映射。例如ABBCD 和BCEDC,对应的mes[]={1,2,1,1,0...0},cip[]={0,1,2,1,1,0...0},排序之后是mes[]={2,1,1,1,0...0},cip[]={2,1,1,1,0...0},那么就存在映射B->C,A C D分别映射B D E。

参考代码

#include<iostream>
#include<string>
#include<algorithm>
#include<memory.h>
#define maxn 101
#define alpha 26
using namespace std;

int main()//AC
{
    int mes[alpha]={0},cip[alpha]={0};
    string list1,list2;
    while(cin>>list1>>list2){
            if(list1.size()!=list2.size()) {cout<<"NO\n";continue;}
            for(size_t i=0;i<list1.size();++i)
                cip[list1[i]-'A']++,mes[list2[i]-'A']++;
            sort(cip,cip+alpha);sort(mes,mes+alpha);
            int i=0;
            for(;i<alpha;i++)
                if(cip[i]!=mes[i])
                    {cout<<"NO\n";break;}
            if(i==alpha)
                cout<<"YES\n";
            memset(mes,0,alpha*sizeof(int));
            memset(cip,0,alpha*sizeof(int));
    }
    return 0;
}

优化与改进

在排序之后比较的循环中,可以不需要26次,只要比较max(list1.size(),list2.size())次。

UVa链接

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=446&page=show_problem&problem=4085

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值