Pimp My Ride(poj 2490)

Pimp My Ride
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 1633 Accepted: 494

Description

Background 
Today, there are quite a few cars, motorcycles, trucks and other vehicles out there on the streets that would seriously need some refurbishment. You have taken on this job, ripping off a few dollars from a major TV station along the way. 
Of course, there's a lot of work to do, and you have decided that it's getting too much. Therefore you want to have the various jobs like painting, interior decoration and so on done by garages. Unfortunately, those garages are very specialized, so you need different garages for different jobs. More so, they tend to charge you the more the better the overall appearance of the car is. That is, a painter might charge more for a car whose interior is all leather. As those "surcharges" depend on what job is done and which jobs have been done before, you are currently trying to save money by finding an optimal order for those jobs. 
Problem 
Individual jobs are numbered 1 through n. Given the base price p for each job and a surcharge s (in US$) for every pair of jobs (i, j) with i != j, meaning that you have to pay additional $s for job i, if and only if job j was completed before, you are to compute the minimum total costs needed to finish all jobs.

Input

The first line contains the number of scenarios. For each scenario, an integer number of jobs n, 1 <= n <= 14, is given. Then follow n lines, each containing exactly n integers. The i-th line contains the surcharges that have to be paid in garage number i for the i-th job and the base price for job i. More precisely, on the i-th line, the i-th integer is the base price for job i and the j-th integer (j != i) is the surcharge for job i that applies if job j has been done before. The prices will be non-negative integers smaller than or equal to 100000.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line: 
"You have officially been pimped for only $p" 
with p being the minimum total price. Terminate the output for the scenario with a blank line.

Sample Input

2
2
10 10
9000 10
3
14 23 0
0 14 0
1000 9500 14

Sample Output

Scenario #1:
You have officially been pimped for only $30

Scenario #2:
You have officially been pimped for only $42

状压dp

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#define INF 0x3f3f3f3f

using namespace std;

int T,N;
int a[16];
int job[16][16];
int dp[1<<15];

void init()
{
    a[1]=1;
    for(int i=2;i<16;i++){
        a[i]=a[i-1]*2;
    }
}

int get(int s,int j)
{
    int sum=job[j][j];
    for(int i=1;i<=N;i++){
        if((s&a[i])!=0){
            sum+=job[j][i];
        }
    }
    return sum;
}

void DP()
{
    memset(dp,INF,sizeof(dp));
    dp[0]=0;
    int len=1<<N;
    for(int i=0;i<len;i++){
        for(int j=1;j<=N;j++){
            if((i&a[j])==0){
                int to=i+a[j];
                int t=get(i,j);
                dp[to]=min(dp[to],dp[i]+t);
            }
        }
    }
}

int main()
{
    cin>>T;
    int counts=0;
    while(T--){
        counts++;
        init();
        cin>>N;
        for(int i=1;i<=N;i++){
            for(int j=1;j<=N;j++){
                cin>>job[i][j];
            }
        }
        DP();
        cout<<"Scenario #"<<counts<<':'<<endl;
        cout<<"You have officially been pimped for only $"<<dp[(1<<N)-1]<<endl;
        cout<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值