D - array array array HDU - 6197 csdn-博客
One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo’s path to escape from the museum. But Kiddo didn’t want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: “I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. ” Conan: “emmmmm…” Now, Conan seems to be in trouble, can you help him?
Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2…An.
1≤T≤20
1≤n≤105
0≤k≤n
1≤Ai≤105
Output
For each test case, please output “A is a magic array.” if it is a magic array. Otherwise, output “A is not a magic array.” (without quotes).
Sample Input
3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6
Sample Output
A is a magic array.
A is a magic array.
A is not a magic array.
- 题意:给你一个大小为n的数组和一个值k,判断能否在删去k个之后该数组满足非递增序列或者给递减序列
- 题解:直接用一个数组存储递增的序列,当发现有一个出现递减数值是把这个值插进这个数组lower_bound查找的位置即可。
#include<bits/stdc++.h>
#define endl '\n'
#define pb push_back
#define mp make_pair
#define _ ios::sync_with_stdio(false)
bool SUBMIT = 1;
typedef long long ll;
using namespace std;
const double PI = acos(-1);
const int inf = 1e5+100;
int sn[inf],dp[inf];
int n,k;
int main()
{
if(!SUBMIT)freopen("i.txt","r",stdin);else _;
int t;cin>>t;
while(t--)
{
cin>>n>>k;
for(int i=0;i<n;i++)cin>>sn[i];
dp[0]=sn[0];
int j=1;
for(int i=1;i<n;i++)
{
if(sn[i]>dp[j-1])dp[j++]=sn[i];
else{
int h=lower_bound(dp,dp+j,sn[i])-dp;
dp[h]=sn[i];
}
}
if(j+k>=n){
cout<<"A is a magic array."<<endl;continue;
}
dp[0]=sn[n-1];
j=1;
for(int i=n-2;i>=0;i--)
{
if(sn[i]>dp[j-1])dp[j++]=sn[i];
else{
int h=lower_bound(dp,dp+j,sn[i])-dp;
dp[h]=sn[i];
}
}
if(j+k>=n){
cout<<"A is a magic array."<<endl;continue;
}
cout<<"A is not a magic array."<<endl;
}
return 0;
}