数据结构---04-树7 二叉搜索树的操作集(30 分)

04-树7 二叉搜索树的操作集(30 分)

本题要求实现给定二叉搜索树的5种常用操作。

函数接口定义:

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

其中BinTree结构定义如下:

typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};
  • 函数InsertX插入二叉搜索树BST并返回结果树的根结点指针;
  • 函数DeleteX从二叉搜索树BST中删除,并返回结果树的根结点指针;如果X不在树中,则打印一行Not Found并返回原树的根结点指针;
  • 函数Find在二叉搜索树BST中找到X,返回该结点的指针;如果找不到则返回空指针;
  • 函数FindMin返回二叉搜索树BST中最小元结点的指针;

  • 函数FindMax返回二叉搜索树BST中最大元结点的指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};

void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */
void InorderTraversal( BinTree BT );  /* 中序遍历,由裁判实现,细节不表 */

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

int main()
{
    BinTree BST, MinP, MaxP, Tmp;
    ElementType X;
    int N, i;

    BST = NULL;
    scanf("%d", &N);
    for ( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Insert(BST, X);
    }
    printf("Preorder:"); PreorderTraversal(BST); printf("\n");
    MinP = FindMin(BST);
    MaxP = FindMax(BST);
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        Tmp = Find(BST, X);
        if (Tmp == NULL) printf("%d is not found\n", X);
        else {
            printf("%d is found\n", Tmp->Data);
            if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
            if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
        }
    }
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Delete(BST, X);
    }
    printf("Inorder:"); InorderTraversal(BST); printf("\n");

    return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:

10
5 8 6 2 4 1 0 10 9 7
5
6 3 10 0 5
5
5 7 0 10 3

输出样例:

Preorder: 5 2 1 0 4 8 6 7 10 9
6 is found
3 is not found
10 is found
10 is the largest key
0 is found
0 is the smallest key
5 is found
Not Found
Inorder: 1 2 4 6 8 9
思路:按照要求写函数;(写树的基本练习,很棒!)
代码如下:
#include<cstdio>
#include<cstdlib>
#include<iostream>
using namespace std;
typedef int ElementType;
typedef struct TNode* Position;
typedef Position BinTree;
struct TNode{
	ElementType Data;
	BinTree Left;
	BinTree Right;
};
BinTree Insert(BinTree BST,ElementType X);//构建树 
BinTree Delete(BinTree BST,ElementType X);//删除元素 
Position Find(BinTree BST,ElementType X);//查找某一元素 
Position FindMin(BinTree BST);
Position FindMax(BinTree BST);
void PreorderTravesal(BinTree BT){// 前序遍历 (格式写法一)
	if(!BT) return ;
	printf(" %d",BT->Data);
	PreorderTravesal(BT->Left);
	PreorderTravesal(BT->Right);
} 
void InorderTraversal(BinTree BT){//中顺遍历 
    if (!BT) return;      
    PreorderTravesal(BT->Left);  
    printf(" %d", BT->Data);  
    PreorderTravesal(BT->Right);  
}  
void InorderTravesal(BinTree BT){//后续遍历 (格式写法二)
	if(BT){
		InorderTravesal(BT->Left);
		printf(" %d",BT->Data);
		InorderTravesal(BT->Right);}
}
int main()
{
	BinTree BST,MinP,MaxP,Tmp;
	ElementType X;
	int N,i;
	BST=NULL;
	cin>>N;
	for(i=0;i<N;i++){
		cin>>X;
		BST=Insert(BST,X);
	}
	printf("Preorder:");
	PreorderTravesal(BST);printf("\n");
	MinP=FindMin(BST);
	MaxP=FindMax(BST);
	cin>>N;
	for(i=0;i<N;i++){
		cin>>X;
		Tmp=Find(BST,X);
		if(Tmp==NULL) printf("%d id not found\n",X);
		else{
			printf("%d is found\n",Tmp->Data);
			if(Tmp==MinP) printf("%d is the smallest key\n",Tmp->Data);
			if(Tmp==MaxP) printf("%d is the largest key\n",Tmp->Data);
		}
	} 
	cin>>N;
	for(i=0;i<N;i++){
		cin>>X;
		BST=Delete(BST,X);
	}
	printf("Inorder:");
	InorderTravesal(BST);
	printf("\n");
	return 0;
}
BinTree Insert(BinTree BST,ElementType X){ //构建树,每次构建,(原则:大于父截点的放在左边,小于父截点的放在右边。),便于查找 
	if(!BST){
		BST=(BinTree)malloc(sizeof(struct TNode));
		//BST=new struct TNode;
		BST->Data=X;
		BST->Left=NULL;
		BST->Right=NULL; 
	}
	else if(X<BST->Data)
		BST->Left=Insert(BST->Left,X);
	else if(X>BST->Data)
		BST->Right=Insert(BST->Right,X); 
	return BST;
}
BinTree Delete(BinTree BST,ElementType X){//删除元素 
	Position Tmp;
	if(!BST)
		printf("Not Found\n");
	else if(X<BST->Data)
		BST->Left=Delete(BST->Left,X);
	else if(X>BST->Data)
		BST->Right=Delete(BST->Right,X);
	else{
		if(BST->Left&&BST->Right){
			Tmp=FindMax(BST->Left);
			BST->Data=Tmp->Data;
			BST->Left=Delete(BST->Left,Tmp->Data);
		}
		else{
			Tmp=BST;
			if(!BST->Left)
				BST=BST->Right;
			else
				BST=BST->Left;
			free(Tmp); 
		}
	} 
	return BST;
}
Position Find(BinTree BST,ElementType X){//查找某一元素 
	while(BST&&(X!=BST->Data)){
		if(X<BST->Data)
			BST=BST->Left;
		else
			BST=BST->Right;
	}
	return BST;
}
Position FindMin(BinTree BST){
	if(BST){
		while(BST->Left)
		BST=BST->Left;
	} 
	return BST;
}
Position FindMax(BinTree BST){
	if(BST){
		while(BST->Right)
			BST=BST->Right; 
	}
	return BST;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值