(HDU2052 C++) Picture

Picture

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 37172 Accepted Submission(s): 18224

Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input

3 2

Sample Output

±–+
| |
| |
±–+


题意:输入两个数作为长方形的长和高,按照给定的样例输出一个长方形

解题思路:
1、第一行和最后一行为一类,首项和尾项为“+”,其余为“-”;
2、其余各行为一类,首项和尾项为“+”,其余为空格。

源代码为:

#include<iostream>
using namespace std;
int main()
{
	int n, m;
	while (cin >> n >> m)
	{
		for (int i = 1; i <= m+2; i++)
		{
			if (i == 1 || i == m+2)
			{
				for (int j = 1; j <= n + 2; j++)
				{
					if (j == 1)
						cout << "+";
					else if (j == (n + 2))
						cout << "+" << endl;
					else
						cout << "-";
				}
			}
			else
				for (int j = 1; j <= n+2; j++)
				{
					if (j == 1)
						cout << "|";
					else if (j == n + 2)
						cout << "|" << endl;
					else
						cout << " ";
				}
			
		}
		cout << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值