PAT 甲级 1045 Favorite Color Stripe (30分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

很有难度的一题,要求熟悉最长不下降子序列LIS问题解法的本质。喜欢的颜色顺序是2 3 1 5 6 ,看上去没有任何关系。作一个映射,把喜欢的颜色给赋上对应的权值 2对1 3对2  1对3  5对4  6对5。待求的序列L 每个数给赋上了相应权值。找出序列L 的最长不下降子序列即可。

dp数组初始化赋值为1.对于以L[ i ]为结尾的最长不下降子序列,dp[ i ] 与 dp[ j ]的关系 

dp[i] = max(1,dp[j]+1),j = 1,2...i-1

//  最长不下降子序列,普通序列通过数字赋权值转换待求的序列,再去找LIS
#include <bits/stdc++.h>
#define maxn 10010

using namespace std;

int c[210] = {0};
int l[maxn] = {0};
int dp[maxn] = {0};

int main()
{
    int N,M,a,L;
    cin>>N;
    cin>>M;
    for(int i = 1;i<=M;i++)
    {
        cin>>a;
        c[a] = i;
    }
    cin>>L;
    int num = 0;
    for(int i = 0;i<L;i++)
    {
        cin>>a;
        if(c[a]!=0)
        {
             l[num] = c[a];
             num++;
        }
    }
    int ans = 0;
    for(int i = 0;i<num;i++)
    {
        dp[i] = 1;
        for(int j = 0;j<i;j++)
        {
            if(l[i]>=l[j]&&dp[j]+1>dp[i])
            {
                dp[i] = dp[j]+1;
            }
        }
        ans = max(dp[i],ans);
    }
    cout<<ans<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值