java-念整数

/**
 * 题目内容:
 *
 * 你的程序要读入一个整数,范围是[-100000,100000]。然后,用汉语拼音将这个整数的每一位输出出来。
 *
 * 如输入1234,则输出:
 *
 * yi er san si
 *
 * 注意,每个字的拼音之间有一个空格,但是最后的字后面没有空格。当遇到负数时,在输出的开头加上“fu”,如-2341输出为:
 *
 * fu er san si yi
 *
 *
 * 输入格式:
 *
 * 一个整数,范围是[-100000,100000]。
 *
 *
 * 输出格式:
 *
 * 表示这个整数的每一位数字的汉语拼音,每一位数字的拼音之间以空格分隔,末尾没有空格。
 *
 *
 * 输入样例:
 *
 * -30
 *
 *
 * 输出样例:
 *
 * fu san ling
 */
import java.util.Scanner;


public class TestFourTwo {
    public static void main(String[] args){
        Scanner in = new Scanner(System.in);
        int num = in.nextInt();
        int[] n = new int[10];
        int count = 0;
        if(num>=-10000 && num<=10000){
            if(num<0){
                System.out.print("fu"+" ");
                num= -num;
            }
            if(num ==0){
                System.out.println("ling");
            }else {
                for (int i = 0; num != 0; i++, count++) {
                    n[i] = num % 10;
                    num = num / 10;
                }
                for (int i = count - 1; i >= 0; i--) {
                    switch (n[i]) {
                        case 0:
                            System.out.print("ling");
                            break;
                        case 1:
                            System.out.print("yi");
                            break;
                        case 2:
                            System.out.print("er");
                            break;
                        case 3:
                            System.out.print("san");
                            break;
                        case 4:
                            System.out.print("si");
                            break;
                        case 5:
                            System.out.print("wu");
                            break;
                        case 6:
                            System.out.print("liu");
                            break;
                        case 7:
                            System.out.print("qi");
                            break;
                        case 8:
                            System.out.print("ba");
                            break;
                        case 9:
                            System.out.print("jiu");
                            break;
                        default:
                            System.out.println("error");

                    }
                    if (i != 0) {
                        System.out.print(" ");
                    }
                }
            }

        }else{
            System.out.println("error");
        }


    }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值