Java求大数的n 次方(hdu1063)

Exponentiation

Time Limit: 2000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10551    Accepted Submission(s): 3081


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
 

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 

Sample Input
 
 
95.123 120.4321 205.1234 156.7592 998.999 101.0100 12
 
Sample Output
 
 
548815620517731830194541.899025343415715973535967221869852721.0000000514855464107695612199451127676715483848176020072635120383542976301346240143992025569.92857370126648804114665499331870370751166629547672049395302429448126.76412102161816443020690903717327667290429072743629540498.1075960194566517745610440100011.126825030131969720661201
 

Source
 

Recommend

PrincetonBoy   |   We have carefully selected several similar problems for you:  1042 1047 1316 1753 1715 

代码:

import java.math.BigDecimal;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
		Scanner s=new Scanner(System.in);
	   while(s.hasNext())//如果此扫描器的输入中有另一个标记,则返回 true
	   {
		    boolean f=false;
		    BigDecimal big=s.nextBigDecimal();
		    int r=s.nextInt();
		    big=big.pow(r);
			String str=big.toPlainString();//返回不带指数字段的此 BigDecimal 的字符串表示形式
			if(str.substring(0,1).equals("0"))//判断求r次方后,BigDecimal的字符串表示形式的第一个字符是否为零
				f=true;
			big=big.stripTrailingZeros();//去除末尾多余的0
			str=big.toPlainString();
			if(f)
			{
				f=false;
				str=str.substring(1);
			}
			System.out.println(str);
		}
	}
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值