A+B for Input-Output Practice(1089-1096)

1、Your task is to Calculate a + b.

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20
Sample Output
6
30

#include<iostream>
using namespace std;

int main() {
	int a, b;
	while (cin>>a>>b) {
		cout << a + b << endl;
	}
	return 0;
}

2、Your task is to Calculate a + b.

Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
2
1 5
10 20
Sample Output
6
30

#include<iostream>
using namespace std;

int main() {
	int a, b,n;
	cin >> n;
	while (n--) {
		cin >> a >> b;
		cout << a + b << endl;
	}
	return 0;
}

3、Your task is to Calculate a + b

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20
0 0
Sample Output
6
30

#include<iostream>
using namespace std;

int main() {
	int a, b;
	while (cin>>a>>b) {
		if (a == 0 && b == 0) return 0;
		cout << a + b << endl;
	}
	return 0;
}

4、Your task is to Calculate the sum of some integers.

Iuput
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15

#include<iostream>
using namespace std;

int main() {
	int n,sum;
	while (cin>>n) {
		sum = 0;//注意sum初始化的位置
		if (n == 0) return 0;
		int* a = new int[n];//数组的定义
		for (int i = 0; i < n; i++) {
			cin >> a[i];
		}
		for (int i = 0; i < n; i++) {
			sum = sum + a[i];
		}
		cout << sum << endl;
	}
}

5、Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
Sample Output
10
15

#include<iostream>
using namespace std;

int main() {
	int n,m,sum;
	cin >> n;
	while (n != 0) {
		n--;
		sum = 0;
		cin >> m;
		int* a = new int[m];
		for (int i = 0; i < m; i++) {
			cin >> a[i];
		}
		for (int i = 0; i < m; i++) {
			sum = sum + a[i];
		}
		cout << sum << endl;
	}
}

6、Your task is to calculate the sum of some integers.

Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.
output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input
4 1 2 3 4
5 1 2 3 4 5
Sample output
10
15

#include<iostream>
using namespace std;

int main() {
	int m,sum;
	while (cin >> m) {
		sum = 0;
		int* a = new int[m];
		for (int i = 0; i < m; i++) {
			cin >> a[i];
		}
		for (int i = 0; i < m; i++) {
			sum = sum + a[i];
		}
		cout << sum << endl;
	}
}

7、Your task is to Calculate a + b.

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.
Sample Input
1 5
10 20
Sample Output
6

30

#include<iostream>
using namespace std;

int main() {
	int a, b;
	while (cin >> a >> b) {
		cout << a + b << endl;
		cout << endl;
	}
}

8、Your task is to calculate the sum of some integers

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10

15

6

//运行时出现了Presentation Error,原因是没有注意到输出结果之间存在空行,但最后一个结果之后没有空行
#include<iostream>
using namespace std;

int main() {
	int n,m,sum;
	cin >> n;
	while (n != 0) {
		n--;
		sum = 0;
		cin >> m;
		int* a = new int[m];
		for (int i = 0; i < m; i++) {
			cin >> a[i];
		}
		for (int i = 0; i < m; i++) {
			sum = sum + a[i];
		}
		cout << sum << endl<<endl;

	}
}
//Accepted结果
#include<iostream>
using namespace std;

int main() {
 	int n, m,s, sum,j=0;
 	cin >> n;
 	s = n;
 	int* count = new int[n];
 	while (n != 0) {
 	 	n--;
  		sum = 0;
  		cin >> m;
  		int* a = new int[m];
  		for (int i = 0; i < m; i++) {
   			cin >> a[i];
 	        }
  	        for (int i = 0; i < m; i++) {
 	                sum = sum + a[i];
 	        }
  	        count[j++] = sum;
       }
       for (int i = 0; i < s; i++) {
 	        cout << count[i] << endl ;
 	        if (i != s - 1)
   	     		cout << endl;
       }
	 
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值