POJ2051 Argus 堆的应用

Argus

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

For the Argus, we use the following instruction to register a query: 
Register Q_num Period
Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005

题意:给出若干任务的id和执行时间间隔,按照执行的时间顺序输出要求的前k个任务的id,同时执行的任务按id号升序输出。

分析:最小堆的应用。根据初始信息按时间和id顺序建立最小堆,每输出一个任务id后将其时间加上时间间隔重新调整。堆相关操作见堆排序操作

#include<iostream>
#include<string>
using namespace std;

struct Node {
	int time;    //执行时间
	int id;   
	int per; //时间间隔
}Nodes[3001];
int Length;

bool LT(Node a, Node b)    //优先级比较函数,true则表示a小于b
{
	if (a.time == b.time)
		return a.id > b.id;
	else
		return a.time > b.time;
}
void heapify(int s)
{
	Node rc = Nodes[s];
	for (int j = s * 2; j <= Length; j *= 2)
	{
		if (j < Length&&LT(Nodes[j], Nodes[j + 1]))		j++;
		if (LT(Nodes[j], rc))	break;
		Nodes[s] = Nodes[j];
		s = j;
	}
	Nodes[s] = rc;
}
void build_heap()
{
	for (int i = Length / 2; i > 0; i--)
	{
		heapify(i);
	}
}
int main()
{
	string str;
	int num;
	while (cin >> str, str.compare("#") != 0)
	{
		Length++;
		cin >> Nodes[Length].id >> Nodes[Length].per;
		Nodes[Length].time = Nodes[Length].per;    //时间进行初始化
	}
	cin >> num;
	build_heap();
	while (num--)
	{
		cout << Nodes[1].id << endl;
		Nodes[1].time += Nodes[1].per;    //修改执行时间
		heapify(1);

	}
	return 0;
}

利用STL里面的优先队列:

#include<iostream>  
#include<string>  
#include<queue>  
using namespace std;

struct task {
	int id;
	int period;
	int time;
	bool operator<(const task &a) const
	{
		return time>a.time || (time == a.time&&id>a.id);
	}
	task(int id, int period, int time) :id(id), period(period), time(time) {}
};

int main()
{
	priority_queue<task> q;
	string str;
	int n;
	while (cin >> str, str.compare("#") != 0)
	{
		int id, per;
		cin >> id >> per;
		q.push(task(id,per,per));
	}
	cin >> n;
	while (n--)
	{
		task ret = q.top();
		q.pop();
		cout << ret.id << endl;
		q.push(task(ret.id, ret.period, ret.time + ret.period));
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值