POJ1724 ROADS Dijkstra+优先队列

ROADS

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

题意:给出n个城市以及m条有向道路,每条道路:s,d,l,t分别表示起点,终点,长度,收费。现在某人共有k钱币,问从1能否到达n,若能则输出在满足花费不超过k的情况下的最短路径长度。

方法1 优先队列+dijkstra

利用邻接表表示,建立优先队列,消费k钱币内能到达的点则入队,通过对路径长度排序每次取出最短路径的终点,若为点N则输出该路径长度,否则继续更新与它相邻的点。

Memory: 1280K    Time : 47MS
#include<iostream>
#include<algorithm>
#include<queue>

using namespace std;
const int maxn = 10005;
int K, N, R, num, first[maxn];

struct Edge {
	int v, len, cost;
	int next;
	Edge(int v=0, int len=0, int toll=0, int next=-1) :
		v(v), len(len), cost(toll), next(next){}
}edge[maxn];
struct node {
	int v, dis, cost;
	node(int v=0, int dis=0, int cost=0) :v(v), dis(dis), cost(cost) {}
	bool operator<(const node& other)const
	{
		return dis > other.dis;
	}
};

void addedge(int u, int v, int len, int toll)
{
	edge[num] = Edge(v, len, toll, first[u]);
	first[u] = num++;
}
void dij()
{
	priority_queue<node> que;
	node node0(1, 0, 0),cur;
	que.push(node0);
	while (!que.empty())
	{
		cur = que.top(); que.pop();
		if (cur.v == N)
		{//走到点N则输出
			cout << cur.dis << endl;
			return;
		}

		for (int i = first[cur.v]; i != -1; i = edge[i].next)
		{//更新相邻点
			if (cur.cost + edge[i].cost <= K)
			{
				node0.v = edge[i].v;
				node0.dis = cur.dis + edge[i].len;
				node0.cost = cur.cost + edge[i].cost;
				que.push(node0);
			}
		}
	}
	cout << -1 << endl;

}
int main()
{
	int s, d, l, t;
	cin >> K >> N >> R;

	num = 0;
	memset(first, -1, sizeof(first));

	for (int i = 0; i < R; i++)
	{
		scanf("%d%d%d%d", &s, &d, &l, &t);
		addedge(s, d, l, t);
	}
	dij();
	return 0;
}

方法2 深度优先搜索:

Memory: 464K    Time : 94MS
#include<iostream>
#include<algorithm>
#include<queue>

using namespace std;
const int maxn = 10005,inf=1000000;
int K, N, R, num, ans, first[maxn];
bool vis[maxn];
struct Edge {
	int v, len, cost;
	int next;
	Edge(int v=0, int len=0, int toll=0, int next=-1) :
		v(v), len(len), cost(toll), next(next){}
}edge[maxn];
struct node {
	int v, dis, cost;
	node(int v=0, int dis=0, int cost=0) :v(v), dis(dis), cost(cost) {}
	bool operator<(const node& other)const
	{
		return dis > other.dis;
	}
};

void addedge(int u, int v, int len, int toll)
{
	edge[num] = Edge(v, len, toll, first[u]);
	first[u] = num++;
}
void dfs(int v, int dis, int money)
{
	if (dis > ans) return; //剪枝:比目前最短距离大则不再继续搜索
	if (v == N&&money >= 0 && dis < ans) ans = dis;//记录最短距离
	for (int i = first[v]; i != -1; i = edge[i].next)
	{
		Edge e = edge[i];
		if (!vis[e.v] && money >= e.cost)
		{
			vis[e.v] = true;
			dfs(e.v, dis + e.len, money - e.cost);
			vis[e.v] = false;
		}
	}

}
int main()
{
	int s, d, l, t;
	cin >> K >> N >> R;

	num = 0;
	memset(first, -1, sizeof(first));
	memset(vis, false, sizeof(vis));

	for (int i = 0; i < R; i++)
	{
		scanf("%d%d%d%d", &s, &d, &l, &t);
		addedge(s, d, l, t);
	}
	ans = inf;vis[1]=true;
	dfs(1, 0, K);
	printf(ans < inf ? "%d\n" : "-1\n", ans);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值