POJ 2485 Highways Kruskal最小生成树

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

 

题意:给定N个城市间距离,若要修建公路使所有城市相互连接,求最长公路的最小值

 

#include<iostream>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=500; 
int N,num,fa[maxn];
struct Edge{
	int u,v,len;
	Edge(){	}
	Edge(int u,int v,int len):
		u(u),v(v),len(len){}
}edge[maxn*maxn];
bool comp(const Edge& e1,const Edge& e2)
{
	return e1.len<e2.len;
}
void init()
{
	for(int i=0;i<N;i++)
		fa[i]=i;
}
int find(int x)
{
	if(fa[x]!=x)
	{
		fa[x]=find(fa[x]);
	}
	return fa[x];
}
void unite(int x,int y)
{
	x=find(x),y=find(y);
	if(x!=y)
	{
		fa[x]=y;
	}	
}
bool same(int x,int y)
{
	return find(x)==find(y);
}
int kruskal()
{
	int res,m=0;
	init();
	sort(edge,edge+num,comp);//对边进行升序排序 
	for(int i=0;i<num;i++)
	{
		Edge e=edge[i];
		if(!same(e.u,e.v))
		{//属于不同连通分量 
			unite(e.u,e.v);
			if(++m==N-1)
			{//最小生成树最后一个边即为最大边 
				return e.len;
			}
		}
	}
	return -1; 
}
int main()
{
	int T;
	cin>>T; 
	while(T--)
	{
		cin>>N;
		num=0;//记录边数 
		for(int i=0;i<N;i++)
			for(int j=0;j<N;j++)
			{
				int len;
				scanf("%d",&len);
				if(j>i)//只记录矩阵上三角 
					edge[num++]=Edge(i,j,len);
			}
		cout<<kruskal()<<endl;	
	} 
	return 0;
}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值