I love sneakers!@HDU 3033

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store. 


There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand. 
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice. 
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

Input

Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

Output

For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

Sample Input

5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66

Sample Output

255

题目分析:

这是一个分组背包的问题,可以将dp设置为二维数组,此时行代表种类,列代表解。

采用01背包的解法是,二维数组形式dp要注意到上下行之间的联系,具体分析看代码注释。 

 

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int dp[13][10003];//dp[i][j]:i代表品牌,j代表背包大小,即金额
int n,m,k;
int brand[10003],price[10003],val[10003];//分别代表所属品牌,价格,价值

int main(){
    while(~scanf("%d%d%d",&n,&m,&k)){
        memset(dp,-1,sizeof(dp));//初始化为-1代表一开始都是不满足需求
        for(int i=0;i<=m;++i) dp[0][i] = 0;
        for(int i=1;i<=n;++i){
            scanf("%d%d%d",&brand[i],&price[i],&val[i]);
        }
        for(int i=1;i<=k;++i){
            for(int j=1;j<=n;++j){ //这一层循环的目的是满足每一品牌至少买一双鞋的条件
                if(brand[j] == i){
                    for(int l=m;l>=price[j];--l){
                        dp[i][l] =
                    max(max(dp[i][l],dp[i][l-price[j]]+val[j]),dp[i-1][l-price[j]]+val[j]);

                    //dp[i][l]是不选择该鞋子
                    //dp[i-1][l-price[j]]+val[j]是选择且第一次选该鞋子
                    //dp[i][l-price[j]]+val[j]是选择且不是第一次选择该鞋子
                    }
                }
            }
        }
        if(dp[k][m] == -1){
            cout << "Impossible" << endl;
        }
        else cout << dp[k][m] << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值