Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime

 

从码云上面下载了一个开源项目,启动报错。原因是node-sass版本有问题

我的node-v版本是

caideyao@caideyaodeMacBook-Pro ~ % node -v
v12.18.3

我的npm -v版本是

caideyao@caideyaodeMacBook-Pro ~ % npm -v
6.14.7

我的cnpm版本是

caideyao@caideyaodeMacBook-Pro ~ % cnpm -v
cnpm@6.1.1 (/usr/local/lib/node_modules/cnpm/lib/parse_argv.js)
npm@6.14.7 (/usr/local/lib/node_modules/cnpm/node_modules/npm/lib/npm.js)
node@12.18.3 (/usr/local/bin/node)
npminstall@3.27.0 (/usr/local/lib/node_modules/cnpm/node_modules/npminstall/lib/index.js)
prefix=/usr/local 
darwin x64 19.6.0 
registry=https://r.npm.taobao.org

原来项目的版本是4.9.0,我们升级到最新到版本

npm rebuild node-sass

或者自己手动升级:

1.先卸载

npm uninstall --save node-sass

2.清除缓存

npm cache clean -f

3.升级node-sass模块

npm install --save node-sass

最后我使用到node-sass的版本是4.14.1

参数博客

 

 

©️2020 CSDN 皮肤主题: 深蓝海洋 设计师:CSDN官方博客 返回首页