Lake Counting (POJ No. 2386) 穷竭搜索 简单dfs (有多少水洼)

                                                        Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

题解

题的大意为:有一个大小为N*M的园子,雨后集起了水。八联通的积水被认为是连在一起的。请求出园子里中共有多少水洼?(八联通是指下图中相对W的*的部分)  (N,M≤100)
* * * 
* w * 
* * *

从任意的W开始,不停地把邻接的部分用' . '代替。1次DFS后与初始的这个W连接的所有就都被替换成了' . ',调用一次,这个位置的周围八个方位的水洼变成陆地,相当于一片水洼。所以调用几次,几片水洼

复杂度为 8 × N × M = N × M

# include <cstdio>

using namespace std;
char s[105][105];
int n, m;
 
void dfs(int x, int y)  //把与之相连的水洼变成陆地,递归一次相当于有一片积水 
{
	s[x][y] = '.';
	
	int xx, yy;
	for(int i=-1;i<=1;i++)
		for(int j=-1;j<=1;j++)
		{
			xx = x+i;
			yy = y+j;
			if(xx>=0&&xx<n&&yy>=0&&yy<m&&s[xx][yy]=='W') dfs(xx,yy);
		}
	
}

int main()
{
	scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++) scanf("%s",s[i]);
	
	int ans = 0;
	for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
			if(s[i][j]=='W')
			{
				dfs(i,j);
				ans++;
			}
	
	printf("%d\n",ans);
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值