Telefraud Detection

7-3 Telefraud Detection (25 分)

Telefraud(电信诈骗) remains a common and persistent problem in our society. In some cases, unsuspecting victims lose their entire life savings. To stop this crime, you are supposed to write a program to detect those suspects from a huge amount of phone call records.

A person must be detected as a suspect if he/she makes more than K short phone calls to different people everyday, but no more than 20% of these people would call back. And more, if two suspects are calling each other, we say they might belong to the same gang. A makes a short phone call to B means that the total duration of the calls from A to B is no more than 5 minutes.

Input Specification:

Each input file contains one test case. For each case, the first line gives 3 positive integers K (≤500, the threshold(阈值) of the amount of short phone calls), N (≤10​3​​ , the number of different phone numbers), and M (≤10​5​​ , the number of phone call records). Then M lines of one day’s records are given, each in the format:

caller receiver duration

where caller and receiver are numbered from 1 to N, and duration is no more than 1440 minutes in a day.

Output Specification:

Print in each line all the detected suspects in a gang, in ascending order of their numbers. The gangs are printed in ascending order of their first members. The numbers in a line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

If no one is detected, output None instead.

Sample Input 1:

5 15 31
1 4 2
1 5 2
1 5 4
1 7 5
1 8 3
1 9 1
1 6 5
1 15 2
1 15 5
3 2 2
3 5 15
3 13 1
3 12 1
3 14 1
3 10 2
3 11 5
5 2 1
5 3 10
5 1 1
5 7 2
5 6 1
5 13 4
5 15 1
11 10 5
12 14 1
6 1 1
6 9 2
6 10 5
6 11 2
6 12 1
6 13 1

Sample Output 1:

3 5
6

Note: In sample 1, although 1 had 9 records, but there were 7 distinct receivers, among which 5 and 15 both had conversations lasted more than 5 minutes in total. Hence 1 had made 5 short phone calls and didn’t exceed the threshold 5, and therefore is not a suspect.

Sample Input 2:

5 7 8
1 2 1
1 3 1
1 4 1
1 5 1
1 6 1
1 7 1
2 1 1
3 1 1

Sample Output 2:

None
#include<bits/stdc++.h>
using namespace std;
int K, N, M;
int G[1008][1008];//G[i][j]表示i向j电话打了G[i][j]分钟。
vector<int> ans[1008],v;
int father[1008];
int findFather(int x) {
	int z = x;
	while (x != father[x]) {
		x = father[x];
	}
	while (z != father[z]) {
		int a = z;
		z = father[z];
		father[a] = x;
	}
	return x;
}
void Union(int a, int b) {
	int af = findFather(a);
	int bf = findFather(b);
	if (af > bf) swap(af, bf);
	father[bf] = af;
}
int main() {
#ifdef ONLINE_JUDGE
#else
	freopen("Text.txt", "r", stdin);
#endif // ONLINE_JUDGE
	scanf("%d %d %d", &K, &N, &M);
	for (int i = 1; i <= N; i++) father[i] = i;
	for (int i = 0; i < M; i++)
	{
		int u, v, w;
		cin >> u >> v >> w;
		if(u!=v)
			G[u][v] += w;
	}
	for (int i = 1; i <= N; i++) {
		int sum1 = 0, sum2 = 0;
		for (int j = 1; j <= N; j++) {
			if (G[i][j] != 0 && G[i][j] <= 5)
			{
				sum1++;//i向j打电话不高于5分钟的人数统计
				if (G[j][i] != 0) sum2++;//j向i回电话的人数统计。
			}
		}
		if (sum1 > K && double(sum2)/double(sum1)<=0.2) {
		//大于阈值,并且回电话的人数不超过20%。
			v.push_back(i);
		}
	}
	int len = v.size();
	if (len == 0) {
		cout << "None" << endl;
		return 0;
	}
	for (int i = 0; i < len; i++) {
		for (int j = 0; j < len; j++) {
			if (G[v[i]][v[j]] != 0&& G[v[j]][v[i]] != 0) {//嫌疑人中互相有通话记录
				Union(v[i],v[j]);
			}
		}
	}
	for (int i = 0; i < len; i++) {
		ans[findFather(v[i])].push_back(v[i]);
	}
	sort(v.begin(), v.end());
	for (int i = 0; i < len; i++) {
		if (father[v[i]] == v[i]) {
			sort(ans[v[i]].begin(), ans[v[i]].end());
			cout << ans[v[i]][0];
			for (int j = 1; j < ans[v[i]].size(); j++)
				cout << " " << ans[v[i]][j];
			cout << endl;
		}
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值