hdu 5547 数独(DFS)

hdu 5547 数独(DFS)

原题目
Problem Description
Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four 2×2 pieces, every piece contains 1 to 4.

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you’ve passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!

Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of ‘1’, ‘2’, ‘3’, ‘4’). ‘*’ represents that number was removed by Yi Sima.

It’s guaranteed that there will be exactly one way to recover the board.

Output
For each test case, output one line containing Case #x:, where x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.

Sample Input
3


2341
4123
3214
*243
312
421
134
41
*3
2
41
4
2

Sample Output
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123

思路

判断横竖以及四个方格中是否有相同数字
依次搜索中,最后记录数字输出。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
char maps[10][10];
int panduan(int row, int col)
{
    for(int i=0; i<4; i++)//判断列
    {
        if(maps[row][i]==maps[row][col]&&i!=col)
            return 0;
    }
    for(int i=0; i<4; i++)//判断行
    {
        if(maps[i][col]==maps[row][col]&&i!=row)
            return 0;
    }

    int Row, Col;//判断四方格
    if(row%2==1) Row=row-1;
    else Row=row;

    if(col%2==1) Col=col-1;
    else Col=col;

    for(int i=Row; i<=Row+1; i++)
    {
        for(int j=Col; j<=Col+1; j++)
        {
            if(maps[i][j]==maps[row][col]&&i!=row&&j!=col)
                return 0;
        }
    }
    return 1;
}

void DFS(int t)
{
    if(t==16)
    {
        for(int i=0; i<4; i++)
            puts(maps[i]);
        return ;
    }

    int row=t/4;
    int col=t%4;

    if(maps[row][col]=='*')
    {
        for(int i=1; i<=4; i++)
        {
            maps[row][col]=i+'0';
            if(panduan(row, col))
                DFS(t+1);
			maps[row][col]='*';
	        }
    }
    else
        DFS(t+1);
}

int main()
{
    int T, cas=1;
    scanf("%d", &T);

    while(T--)
    {
        for(int i=0; i<4; i++)
            scanf("%s", maps[i]);

        printf("Case #%d:\n", cas++);

        DFS(0);
    }
    return 0;
}

总结

思路很简单 判断时需要注意是不是自己等于自己依次判断,无异常返回1即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值