Dijkstra算法变异 poj 1797

           poj-1797     


Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:

4

题目大意:

给出样例个数,每个样例有n个城市,m条路,之后依次输入i,j,w,表示从i到j权值为w,输出从1到m的所有最短路中最小权值的最大值(即每条路中的最小权值取出,和其他路比较,输出这些权值中最大的)。

Dijkstra算法的变异,写着到题时间,没太理解算法执行过程,看了题解才知道,在这说出我的理解。

解题思路:就是算法的变形,要把握Dijkstra算法的执行过程,依次更改。

代码:

#include<stdio.h>
#include<string.h>
int fun(int a,int b);
int a[1010][1010];
int main()
{
	int i,t,j,k,m,n,min,inf,t1,t2,t3,c,v;
	int b[1010],dis[1010];
	scanf("%d",&t);
	int f[1010];
	inf =99999999;v=1;
	while(t--)
	{
		scanf("%d%d",&m,&n);
		memset(b,0,sizeof(b));
		for(i=1;i<=m;i++)
		 for(j=1;j<=m;j++)
		   a[i][j]=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&t1,&t2,&t3);
			a[t1][t2]=t3;
			a[t2][t1]=t3;
		  }
	    for(i=1;i<=m;i++)
		   dis[i]=a[1][i];//dis数组中要存入每条路中的最小权值。
		   c=1;
	    while(c<m)
	    {
             min=-1;
            for(i=1;i<=m;i++)
            if(min<dis[i]&&b[i]==0)//这里寻找权值最大的值,因为dis数组中要存最小权值,此次如若寻找最小值,                                   //将会覆盖原先的值,这与储存权值最小相矛盾。因此上面初始化时间,将数组初始化为0            {  min=dis[i];   j=i; }
            b[j]=1;            
		    c++;
            for(k=1;k<=m;k++)
            {
               if(b[k]==0&&dis[k]<fun(dis[j],a[j][k]))//fun函数寻找当前节点所储存权值和当前节点所存节点到k节点的最小权值(依次来寻找每条最短路中的最小权值);如若到k节点的最小权值小与函数比较出的节点权值,更新k节点的数据,以此来让所有最小权值中的最大值更新到数组后面。			   {
			      dis[k]=fun(dis[j],a[j][k]);
				  }
			 }
		}
	     printf("Scenario #%d:\n",v);
	     v++;
	     printf("%d\n\n",dis[m]);
	}
	return 0;
} 
int fun(int a,int b)
{
	return a<b?a:b;
}
   
   

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值