HDU 3336 Count the string

                                                                     Count the string

               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                            Total Submission(s): 11389    Accepted Submission(s): 5308


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
 
 
1
4
abab
 
Sample Output
 
 
6
题目大意:
给出一个字符串,求出各子串在字符串中出现次数总和。
解题思路:
运用kmp的next数组求法,再一次感觉到了kmp的强大,佩服那个发明这个算法的人。next数组记录当前长度中最
大的相同的前后缀,该位置数组上有数字代表前面有一段字符在前面出现过,因此每次变量加一,之后加上字符串
长度,因为数组是从0开始的,各位置的数字中不代表它自己本身,因此需要加上。
代码:

#include<stdio.h>

#include<string.h>

char a[200010];

int next[200010];

int len;

void get_()

{

   int i,j;

   i=1;j=0;

   while(i<len)

   {

       if(!j&&a[i]!=a[j])    

   {      

        next[i]=0;      

i++;    

   }  

   else if(j>0&&a[i]!=a[j])     

        j=next[j-1];

   else      

   {     

        next[i]=j+1;     

j++;i++;

   }

  }

}

int main()

{

    int t,i;     

scanf("%d",&t);     

while(t--)

{

    scanf("%d",&len);

scanf("%s",a);

get_();

int sum=0;

for(i=0;i<len;i++)

{

    if(next[i])   

   sum++;

if(sum>10007)   

   sum%=10007;

}

sum+=len;

sum%=10007;

printf("%d\n",sum);

}

return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值