ZCMU 1040: 二哥的困惑 Ⅲ

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.

Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 
Input


The input consists of several test cases. The first line of each case contains two integers m (2<=m<=20) and n (1<=n<=50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros. 

Output


For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 

Sample Input
2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0
Sample Output
Case 1: 2
Case 2: 4

【分析】这题和田忌赛马https://blog.csdn.net/qq_39315193/article/details/81563882解题思路相同,更简单

虽然是多人游戏,如果把其他人看成一队,全针对自己,这样就能保证我赢的是最少的。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int a[1005], b[1005];
bool cmp(int a, int b)
{
    return a > b;
}
int main()
{
    int m,n ;
    int count = 0;
    while(scanf("%d%d",&m,&n))
    {
        if(m==0&&n==0)break;
        count++;
        memset(a , 0 ,sizeof(a));
        int t = 0,win = 0;;
        for(int i =0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a, a + n, cmp);//自己牌a[]降序排列
        for(int i = n*m,j=0;i>0;i--)
        {
            if(i==a[t])
            {
                t++;
                continue;
            }
            b[j] = i;
            j++;
        }//对面牌b[]降序排列

        for(int i = 0,j =0;i<n;i++)//我从大往小出牌
        {
            if(b[j]>a[i])//对手最大的牌能大于我的牌,对面就出最大的(换个理解就是对面用最大的牌耗我最大的牌)
                j++;                                               
            else
                win++;//对面最大的牌小于我的最大的牌,对面就出最小的,j不变表示最大的牌留着
                      //因为不存在两张牌相同,所以不必考虑最小牌耗我的最小牌的情况(当对手最小牌大于我的最小牌)
        }
        printf("Case %d: %d\n" ,count ,win);
    }
    return 0;
}

这篇解题思路很好https://blog.csdn.net/abcjennifer/article/details/5405097

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值