09-排序3 Insertion or Heap Sort (25 分)

09-排序3 Insertion or Heap Sort (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

Note

  1. 接着上题,利用sort找到heap序列中有序和无序的分界点,然后将heap中的堆顶删除

Code

#include<iostream>
#include<algorithm>
using namespace std;
#define MAX 110
int a[MAX], b[MAX], c[MAX], h[MAX];
int size = 0;
void Delete(void){
    int temp = h[size--], i;
    for(i =2; ; i *= 2){
        if(h[i+1] > h[i])   i++;
        if(temp < h[i]) h[i/2] = h[i];
        else break;
    }
    h[i/2] = temp;
}
int main(){
    int num, i;
	h[0] = MAX;
    cin >> num;
    for(int i = 0; i < num; i++){
        cin >> a[i];
    }
    int last = -1, flag = -1;
    for( int i = 0; i < num; i++){   
        cin >> c[i];
        if(last > c[i] && flag == -1) flag = i;
        last = c[i];
    }
    for(i = flag; i < num; i++){
        if(a[i] != c[i]){   cout << "Heap Sort" << endl; break;}
    }
    if( i == num  ){
        cout << "Insertion Sort" << endl;
        sort(c, c + flag +1);
        cout << c[0];
        for(int j = 1; j < num; j++){
            cout << " " << c [j];
        }
    }
    else{
        for(i = 0; i < num; i++){
            b[i] = c[i];
        }    
        sort(b, b + num);
        for(i = num - 1; c[i] == b[i]; i--);
        for(int j = 0; j <= i; j++){
           h[j + 1] = c[j];
        }
        size = i + 1;
        Delete();
        cout << h[1];
        for(int j = 2; j <= size; j++)  cout << " " << h[j];
        for(; i < num; i++ ) cout << " " << b[i];
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值