1047 Student List for Course (25 分)
Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.
Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.
Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
Note
- 题意: 按照学生序输入, 按照课程序列输出
- 思路: vector < string>course 存放有该课程同学的姓名,排序输出
- 问题
- cout可以输出course[i][j] printf不行?
- 最后一个点超时也不知道是输入输出还是思路的问题还是string的问题
Code
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
const int M = 2500;
vector <string> course[M];
int main(){
int stunum, coursenum;
cin >> stunum >> coursenum;
for(int i = 0; i < stunum; i++){
int tempnum;
char name[7];
scanf("%s %d", name, &tempnum);
for(int j = 0; j < tempnum; j++){
int classid;
scanf("%d", &classid);
course[classid].push_back(name);
}
}
for(int i = 1; i <= coursenum; i++){
sort(course[i].begin(), course[i].end(), cmp);
printf("%d %d\n", i, course[i].size());
for(int j = 0; j < course[i].size(); j++){
puts(course[i][j]);
}
}
return 0;
}
Note2
- 建立int的二维数组,course[i][j] = k表示第i号课程上的人的一个列表,k是上这个课的学生的姓名所在的字符数组name[i][j]的i下标
- strcmp返回的不一定是-1,0,1这几个数字,要返回bool变量还需要在后面添加strcmp是大于0还是小于0
Code
#include <iostream>
#include <vector>
#include <algorithm>
#include <string.h>
using namespace std;
char name[40010][5];
vector<int> course[2510];
bool cmp1(int a, int b) {
return strcmp(name[a], name[b]) < 0;
}
int main() {
int n, k;
scanf("%d %d", &n, &k);
for(int i = 0; i < n; i++) {
int cnt, temp;
scanf("%s %d", name[i], &cnt);
for(int j = 0; j < cnt; j++) {
scanf("%d", &temp);
course[temp].push_back(i);
}
}
for(int i = 1; i <= k; i++) {
printf("%d %d\n", i, course[i].size());
sort(course[i].begin(), course[i].end(), cmp1);
for(int j = 0; j < course[i].size(); j++)
printf("%s\n", name[course[i][j]]);
}
return 0;
}