1063 Set Similarity (25 分)

1063 Set Similarity (25 分)

Given two sets of integers, the similarity of the sets is defined to be ​ the number of distinct common numbers shared by the two sets, and ​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10^​​) and followed by M integers in the range [0,10 ^​9​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

Note

  1. 题意; 给一堆集合选两个找相同的个数占总个数的百分比(总个数要去掉相同的)
  2. 思路: set存储 两个变量记录相同过的个数和不同的个数
  3. 障碍: 不同的个数初始化为一个set的size

Code

#include<iostream>
#include<vector>
#include<fstream>
#include<set>
using namespace std;
const int M = 60;
set <int> a[M];
int main(){
    int num;
    //ifstream cin("data.txt");
    cin >> num;
    for(int i = 0; i < num; i++){
        int tempnum;
        cin >> tempnum;
        for(int j = 0; j < tempnum; j++){
            int data;
            cin >> data;
            a[i].insert(data);
        }
    }
    int queries_num;
    cin >> queries_num;
    for(int i = 0; i < queries_num; i++){
        int tempa, tempb;
        int same_cnt = 0, total_cnt;
        cin >> tempa >> tempb;
        tempa--; tempb--;
        total_cnt = a[tempb].size();
        for(auto it = a[tempa].begin(); it != a[tempa].end(); it++){
            if(a[tempb].find(*it) != a[tempb].end()) same_cnt ++;
            else  total_cnt++;
        }
        printf("%.1lf", (double)(same_cnt * 100.0 / (total_cnt)));
        cout << '%' << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值