1099 Build A Binary Search Tree (30 分)

Keywords: BST

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

Note

  1. 题意: 看图能理解
  2. 方法: 输入值排序,模拟前序输入, 层次遍历输

Code

#include<iostream>
#include<fstream>
#include<vector>
#include<cmath>
#include<algorithm>
#include<stack>
#include<queue>
#define MAX 100010
using namespace std;
struct node{	
	int left;
	int right;
}nodes[MAX];
vector <int> input, a;
int main(){
#ifdef _DEBUG
	ifstream cin("data.txt");
#endif
	int num, cnt = 0; 
	cin >> num;
	a.resize(num);
	input.resize(num);
	for(int i = 0; i < num; i++){
		int a , b;
		cin >> a >> b;
		nodes[i].left = a;
		nodes[i].right = b;
	}
	for(int i = 0; i < num; i++){
		cin >> input[i];
	}
	sort(input.begin(), input.end());
	stack<int> s;
	s.push(0);
	while(s.size() > 0){
		int p = s.top();
		while(p >= 0){
			p = nodes[p].left; s.push(p);
		}
		s.pop();
		if(s.size() > 0){
			p = s.top();
			s.pop();
			a[p] = input[cnt++];
			s.push(nodes[p].right);
		}
	}
	queue<int> q;
	q.push(0);
	cout << a[0];
	q.pop();
	if(nodes[0].left >= 0) q.push(nodes[0].left);
	if(nodes[0].right>= 0) q.push(nodes[0].right);
	while(q.size() > 0){
		int temp = q.front();
		q.pop();
		cout << " " << a[temp];
		if(nodes[temp].left >= 0) q.push(nodes[temp].left);
		if(nodes[temp].right>= 0) q.push(nodes[temp].right);
	}


#ifdef _DEBUG
	cin.close();
#endif
	return  0;
}

Note2

  1. 有其他方法,未完待续
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值