1088 Rational Arithmetic (20 分) 简单模拟,gcd, 分式运算, 心态炸裂

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

Note

  1. 题意: 输入两个数,分数形式, 输出这两个数四则运算的真分式形式
    要求:(1)真分式 (2)分母为零则输出Inf (3)负数带括号
  2. 思路,本题做到心态炸裂主要就是因为感觉只是简单模拟,上来就写,导致太多重复代码,进而导致容易出错以及写如此之丑的代码的自责与愧疚, 修修补补两个小时,总算能过
  3. gcd求最大公约数模板
  4. 输入的时候带着其他符号,只会用scanf导致data.txt用不了233,是不是改成用C的对文件了呀

Code

#include<iostream>
#include<algorithm>
#include<fstream>
using namespace std;

long long gcd(long long a,long long b)
{
    return b==0?a:gcd(b,a%b);
}

void func(long long a, long long b){
	int flag = 0;
    if(b == 0) {cout << "Inf" ; return;}
    if(a == 0){cout << 0; return ;}
	if(a < 0 && b > 0 || a > 0 && b < 0) {
		cout  <<  "(-";
		flag = 1;
	}
	long long aa = abs(a), bb = abs(b);
    long long com = gcd(aa, bb);
    if(com > 0){
        aa /= com;
        bb /= com;
    }
    if( aa >= bb && aa % bb != 0){
        long long tema = aa / bb;
        cout << tema <<" " ;
        aa = aa % bb;
    } 
	if(aa % bb == 0){
		cout << aa;
	}else {
		cout << aa << "/" << bb;
	}
    if(flag == 1) cout << ")";
}
int main(){
    long long fenzia, fenmub, fenzib,fenmua;
    int xishua = 0, xinshub = 0, flaga = 0, flagb = 0;
    long long sum_result_fenzi = 0, divide_result_fenzi = 0, muti_result_fenzi = 0, sub_result_fenzi = 0;
    long long sum_result_fenmu = 0, divide_result_fenmu = 0, muti_result_fenmu = 0, sub_result_fenmu = 0;
#ifdef _DEBUG
	ifstream cin("data.txt");
#endif
    scanf("%lld/%lld %lld/%lld", &fenzia, &fenmua, &fenzib, &fenmub);

    sum_result_fenzi = fenzia * fenmub + fenmua * fenzib;   sum_result_fenmu = fenmua * fenmub;
    sub_result_fenzi = fenzia * fenmub - fenmua * fenzib;   sub_result_fenmu = fenmua * fenmub;
    muti_result_fenzi = fenzia * fenzib;    muti_result_fenmu = fenmua * fenmub;
    divide_result_fenzi = fenzia * fenmub;  divide_result_fenmu = fenmua * fenzib;

    func(fenzia, fenmua); cout << " + ";    func(fenzib, fenmub);   cout << " = ";  func(sum_result_fenzi, sum_result_fenmu); 
    cout << endl; 

    func(fenzia, fenmua);   cout << " - ";  func(fenzib, fenmub);   cout << " = ";  func(sub_result_fenzi, sub_result_fenmu);
	cout << endl; 

    func(fenzia, fenmua);   cout << " * ";  func(fenzib, fenmub);   cout << " = ";  func(muti_result_fenzi, muti_result_fenmu);
    cout << endl; 

    func(fenzia, fenmua);   cout << " / ";  func(fenzib, fenmub);   cout << " = ";  func(divide_result_fenzi, divide_result_fenmu);
#ifdef _DUBUG
	cin.close();
#endif
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值