[线性DP LIS]Eating Together(POJ-3670)

Eating Together(POJ-3670)

题目

Description

The cows are so very silly about their dinner partners. They have organized themselves into three groups (conveniently numbered 1, 2, and 3) that insist upon dining together. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 3) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it’s easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ’s job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 111222333 or 333222111 where the cows’ dining groups are sorted in either ascending or descending order by their dinner cards.

FJ is just as lazy as the next fellow. He’s curious: what is the absolute mminimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i describes the i-th cow’s current dining group with a single integer: Di

Output

  • Line 1: A single integer representing the minimum number of changes that must be made so that the final sequence of cows is sorted in either ascending or descending order

Sample Input

5
1
3
2
1
1

Sample Output

1

思路

LIS类型的DP,求把一个序列变成非降序列或者非升序列需要改变数字的最小次数。
只需求出最长非降和非升子序列然后用n减去就是答案了

朴素的DP时间复杂度为 O ( N 2 ) O(N^2) O(N2)意料之中的超时了
所以要用贪心优化的LIS来做这题

代码

TLE的朴素DP

#include<iostream>
#include<math.h>
using namespace std;
typedef long long ll;
const int N=3e4+10;
ll f[N],g[N];
ll a[N];
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)cin>>a[i];

    for(int i=1;i<=n;i++)f[i]=g[i]=1;
    for(int i=1;i<=n;i++)
        for(int j=1;j<i;j++)
        {
            if(a[i]>=a[j])f[i]=max(f[i],f[j]+1);
            if(a[i]<=a[j])g[i]=max(g[i],g[j]+1);
        }
    ll ans=0x3f3f3f3f;
    for(int i=1;i<=n;i++)ans=min(ans,min(n-f[i],n-g[i]));
    cout<<ans;

    return 0;
}

贪心求LIS长度 O ( N l o g N ) O(NlogN) O(NlogN)
以最长上升子序列为例
贪心:我们要找的最优解一定是a[i]尽可能小,f[i]尽可能大的。经过证明可知道a[i]随f[i]单调递增,那么我们可以用二分找到最后一个可以让a[i]接上的位置(指接上之前)
在这里插入图片描述

#include<iostream>
#include<math.h>
#include<cstring>
using namespace std;
typedef long long ll;
const int N=3e4+10;
ll f[N],g[N];
ll a[N],q[N];
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)cin>>a[i];

    int la,lb;
    la=lb=0;
    q[0]=-2e9;//哨兵,防止没有<=a[i]的
    for(int i=0;i<n;i++)
    {
        int l=0,r=la;
        while(l<r)//找位置
        {
            int mid=(l+r+1)>>1;
            if(q[mid]<=a[i])l=mid;
            else r=mid-1;
        }
        la=max(la,r+1);//答案更新
        q[r+1]=a[i];//序列更新
    }
    memset(q,0,sizeof(q));
    q[0]=2e9;
    for(int i=0;i<n;i++)
    {
        int l=0,r=lb;
        while(l<r)
        {
            int mid=(l+r+1)>>1;
            if(q[mid]>=a[i])l=mid;
            else r=mid-1;
        }
        lb=max(lb,r+1);
        q[r+1]=a[i];
    }
    //printf("%d %d\n",la,lb);
    cout<<min(n-la,n-lb);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值