HDU 2602 Bone Collector(经典01背包问题)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=2602

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 77450    Accepted Submission(s): 32095


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

 

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 

 

Sample Output
14
 

 

Author
Teddy
 

 

Source
 
分析:
经典的01背包问题,每个物品只有两种状态,放还是不放
dp[i][j]:即前面i件物品放入一个容量为j的背包可以获得的最大价值
状态转移方程:
dp[i][j]=dp[i-1][j]  j<w[i]
dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i]     j>=w[i]
 
注意:
1.先输入的是物品的价值,而不是重量,题目中好像说反了
2.背包容量可以为0,物品的重量也可以为0
关于第2点的测试数据:
输入
1
5 0
2 4 1 5 1
0 0 1 0 0
输出
12
 
从前往后遍历二维数组
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,c;
        scanf("%d %d",&n,&c);
        int v[n+1],w[n+1];
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&w[i]);
        }
        int dp[n+1][c+1];
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=c;j++)
            {
                if(w[i]<=j)//表示第i个物品放入背包中
                {
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i]);//第i个物品放入之后,那么前面i-1个物品可能会因为剩余空间不够无法放入
                }else//表示第i个物品不放入背包
                {
                    dp[i][j]=dp[i-1][j];//如果第i个物品不放入背包,那么此时的最大价值与放前面i-1个物品的值相等
                }
            }
        }
        printf("%d\n",dp[n][c]);
    }
    return 0;
}

/*
3
5 10
6 3 5 4 6
2 2 6 5 4
5 10
1 2 3 4 5
5 4 3 2 1
5 0
2 4 1 5 1
0 0 1 0 0


15
14
12
*/

 

 从后往前遍历二维数组
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,c;
        scanf("%d %d",&n,&c);
        int v[n+1],w[n+1];
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&w[i]);
        }
        int dp[n+1][c+1];
        memset(dp,0,sizeof(dp));
        for(int j=0;j<=c;j++)
        {
            if(j>=w[n])
            {
                dp[n][j]=v[n];
            }else
            {
                dp[n][j]=0;
            }
        }
        for(int i=n-1;i>=1;i--)
        {
            for(int j=0;j<=c;j++)
            {
                if(j>=w[i])
                {
                    dp[i][j]=max(dp[i+1][j],dp[i+1][j-w[i]]+v[i]);
                }
                else
                {
                    dp[i][j]=dp[i+1][j];
                }
            }
        }
        printf("%d\n",dp[1][c]);
    }
    return 0;
}

/*
3
5 10
6 3 5 4 6
2 2 6 5 4
5 10
1 2 3 4 5
5 4 3 2 1
5 0
2 4 1 5 1
0 0 1 0 0


15
14
12
*/

二者其实是一个方法,只是遍历二维数组的方向有点不同

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值