POJ 1384 Intervals (线性差分约束,根据不等式建图,然后跑spfa)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1384

Intervals

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4841    Accepted Submission(s): 1815


Problem Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output
 

 

Input
The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

 

 

Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.
 

 

Sample Input
5 3 7 3 8 10 3 6 8 1 1 3 1 10 11 1
 

 

Sample Output
6
 

 

Author
1384
 

 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1529  1531  1548  1534  1317 
题目意思:
给出 n 个区间,每个区间有个权值 Ci,最终找出一个最少的数字的集合,使得满足每个区间中至少包含 Ci 个数。
给你几组的a,b,c
从区间a到b(闭区间)选择至少c个数放入集合
要求集合中的数字最少,问你最少多少个数字
 
分析:
f(a)表示从0到a有f(a)个数放入集合
那么a,b,c根据不等式建立边
f(b)-f(a-1)>=c
 
这个不等式的意思是:从区间a,b里面选择至少c个数加入集合
隐藏的不等式:0<=f(i)-f(i-1)<=1
 
变形一下:
f(i)-f(i-1)>=0
f(i-1)-f(i)>=-1
 
根据这三个不等式建立边
找到区间在最左端:minn
找到区间的最右端:maxx
所以这样建立边的话,跑最短路的时候
起点应该是max,终点是min-1
f(max)-f(min-1)>=x
x就是我们需要的结果
code:
#include <iostream>
#include <cstdio>
#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<memory>
#include<queue>
#include<vector>
using namespace std;
#define max_v 50010
#define INF 9999999
int tot;
int head[max_v];
int vis[max_v];
int dis[max_v];
int minn,maxx;
struct node
{
    int u,v,val;
    int next;
}Edge[max_v<<2];
void addEdge(int u,int v,int val)
{
    Edge[tot].u=u;
    Edge[tot].v=v;
    Edge[tot].val=val;
    Edge[tot].next=head[u];
    head[u]=tot++;
}
void spfa()
{
    for(int i=minn-1;i<=maxx;i++)
        dis[i]=-INF;
    queue<int> q;
    dis[maxx]=0;
    vis[maxx]=1;
    q.push(maxx);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u];i!=-1;i=Edge[i].next)
        {
            int v=Edge[i].v;
            if(dis[v]<dis[u]+Edge[i].val)
            {
                dis[v]=dis[u]+Edge[i].val;
                if(!vis[v])
                {
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
    }
    printf("%d\n",dis[minn-1]);
    return ;
}
int main()
{
    int n,a,b,c;
    while(~scanf("%d",&n))
    {
        tot=0;
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        maxx=0;
        minn=INF;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            a++;
            b++;
            minn=min(minn,a);
            maxx=max(maxx,b);
            addEdge(b,a-1,c);
        }
        for(int i=minn;i<=maxx;i++)
        {
            addEdge(i,i-1,0);
            addEdge(i-1,i,-1);
        }
        spfa();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值