Rmice的博客

联系方式1191067121@qq.com

修改maven默认的JRE编译版本1.5,需要根据自己的情况更改为1.7或1.8。
问题:修改maven默认的JRE编译版本1.5,需要根据自己的情况更改为1.7或1.8。
解决办法:pom.xml文件<bulid>中添加<plugins>代码。
       <plugins>
		<!-- 修改maven默认的JRE编译版本 防止maven update project之后 把jre配置的成默认的1.5 根据自己的情况更改为1.7或1.8 -->
		<plugin>
			<groupId>org.apache.maven.plugins</groupId>
			<artifactId>maven-compiler-plugin</artifactId>
			<version>2.3.2</version>
			<configuration>
				<source>1.8</source>
				<target>1.8</target>
			</configuration>
		</plugin>
	</plugins>
阅读更多
文章标签: maven
个人分类: ssm
下一篇cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration。
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

修改maven默认的JRE编译版本1.5,需要根据自己的情况更改为1.7或1.8。

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭