PAT甲组 1087. All Roads Lead to Rome (30)

https://www.patest.cn/contests/pat-a-practise/1087

1087. All Roads Lead to Rome (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<=N<=200), the number of cities, and K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N-1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K lines follow, each describes a route between two cities in the format "City1 City2 Cost". Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:

For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommended. If such a route is still not unique, then we output the one with the maximum average happiness -- it is guaranteed by the judge that such a solution exists and is unique.

Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommended route. Then in the next line, you are supposed to print the route in the format "City1->City2->...->ROM".

Sample Input:
6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1
Sample Output:
3 3 195 97
HZH->PRS->ROM
题意:N个城市,K个无向边,一个起点。除了起点以外每个城市都自带点权( happiness),终点都是ROM。求最短路径,如果最短有多条,选择点权值之和最大的一条,如果点权值之和也一样,就选择平均点权最大的一条。最后还要输出从起点到ROM的路径。

思路:dijkstra算法硬刚↓

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<map>
#include<iostream>
using namespace std;

const int inf = 999999999;

int N,K;//N个城市,K条路径
map<string,int>city_num;//将城市名转换为城市编号
map<int,string>num_city;//将城市编号转换为城市名
bool book[222]={false};
int dis[222],we[222],num[222],pot[222],pre[222];//最短距离,最大点权,最短路径数目,最短路径的顶点个数,前驱点
int Ig[222][222];//无向图
int hp[222];//幸福值
string start,temp1,temp2;
int ed;

void dijkstra(int st)
{
	fill(dis,dis+222,inf);
	fill(we,we+222,0);
	fill(num,num+222,0);
	fill(pot,pot+222,0);
	for(int i=0;i<N;i++)
	{
		pre[i]=i;
	}
	dis[st]=0;
	we[st]=hp[st];
	num[st]=1;
	for(int i=0;i<N;i++)
	{
		int u=-1,min=inf;
		for(int j=0;j<N;j++)
		{
			if(book[j]==false&&dis[j]<min)
			{
				u=j;
				min=dis[j];
			}
		}
		if(u==-1) return;
		book[u]=true;
		for(int v=0;v<N;v++)
		{
			if(book[v]==false&&Ig[u][v]!=inf)
			{
				if(dis[u]+Ig[u][v]<dis[v])
				{
					dis[v]=dis[u]+Ig[u][v];
					we[v]=we[u]+hp[v];
					num[v]=num[u];
					pot[v]=pot[u]+1;
					pre[v]=u;
				}
				else if(dis[u]+Ig[u][v]==dis[v])//相同长度的路径
				{
					num[v]+=num[u];
					if(we[u]+hp[v]>we[v])
					{
						we[v]=we[u]+hp[v];
						pot[v]=pot[u]+1;
						pre[v]=u;
					}
					else if(we[u]+hp[v]==we[v])
					{
						double uu=(we[u]+hp[v])*1.0/(pot[u]+1);
						double vv=we[v]*1.0/pot[v];
						if(uu>vv)
						{
							pot[v]=pot[u]+1;
							pre[v]=u;
						}
					}
				}
			}
		}
	}
}

void showpath(int x)//打印路径
{
	if(x==0)
	{
		cout<<num_city[x];
		return;
	}
	showpath(pre[x]);
	cout<<"->"<<num_city[x];
}

int main()
{
	cin>>N>>K>>start;
	city_num[start]=0;
	num_city[0]=start;//起点城市编号为0
	int temp;
	for(int i=1;i<=N-1;i++)
	{
		cin>>temp1>>temp;
		city_num[temp1]=i;
		num_city[i]=temp1;
		hp[i]=temp;
	}
	fill(Ig[0],Ig[0]+222*222,inf);
	for(int i=0;i<K;i++)
	{
		cin>>temp1>>temp2>>temp;
		int num1,num2;
		num1=city_num[temp1];
		num2=city_num[temp2];
		Ig[num1][num2]=temp;
		Ig[num2][num1]=temp;//无向图两边都要连0w0
	}
	dijkstra(0);
	string em="ROM";
	ed=city_num[em];
	printf("%d %d %d %d\n",num[ed],dis[ed],we[ed],we[ed]/pot[ed]);
	showpath(ed);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
校园悬赏任务平台对字典管理、论坛管理、任务资讯任务资讯公告管理、接取用户管理、任务管理、任务咨询管理、任务收藏管理、任务评价管理、任务订单管理、发布用户管理、管理员管理等进行集中化处理。经过前面自己查阅的网络知识,加上自己在学校课堂上学习的知识,决定开发系统选择小程序模式这种高效率的模式完成系统功能开发。这种模式让操作员基于浏览器的方式进行网站访问,采用的主流的Java语言这种面向对象的语言进行校园悬赏任务平台程序的开发,在数据库的选择上面,选择功能强大的Mysql数据库进行数据的存放操作。校园悬赏任务平台的开发让用户查看任务信息变得容易,让管理员高效管理任务信息。 校园悬赏任务平台具有管理员角色,用户角色,这几个操作权限。 校园悬赏任务平台针对管理员设置的功能有:添加并管理各种类型信息,管理用户账户信息,管理任务信息,管理任务资讯公告信息等内容。 校园悬赏任务平台针对用户设置的功能有:查看并修改个人信息,查看任务信息,查看任务资讯公告信息等内容。 系统登录功能是程序必不可少的功能,在登录页面必填的数据有两项,一项就是账号,另一项数据就是密码,当管理员正确填写并提交这二者数据之后,管理员就可以进入系统后台功能操作区。项目管理页面提供的功能操作有:查看任务,删除任务操作,新增任务操作,修改任务操作。任务资讯公告信息管理页面提供的功能操作有:新增任务资讯公告,修改任务资讯公告,删除任务资讯公告操作。任务资讯公告类型管理页面显示所有任务资讯公告类型,在此页面既可以让管理员添加新的任务资讯公告信息类型,也能对已有的任务资讯公告类型信息执行编辑更新,失效的任务资讯公告类型信息也能让管理员快速删除。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值