题目描述
字符串 APPAPT 中包含了两个单词 PAT,其中第一个 PAT 是第 2 位§,第 4 位(A),第 6 位(T);第二个 PAT 是第 3 位§,第 4 位(A),第 6 位(T)。现给定字符串,问一共可以形成多少个 PAT?
输入格式:
输入只有一行,包含一个字符串,长度不超过
1
0
5
10^5
105,只包含 P、A、T 三种字母。
输出格式:
在一行中输出给定字符串中包含多少个 PAT。由于结果可能比较大,只输出对 1000000007 取余数的结果。
输入样例:
APPAPT
输出样例:
2
思路一
通过逐个扫描 A ,然后判断 A 的左边有多少个 P 和 多少个 T,然后相乘,每次循环都相加除余。最后得出结果。由于时间过长,不能通过测试。
import java.io.*;
import java.util.*;
public class Main {
public static void main(String[] args) throws IOException {
Reader.init(System.in);
String str = Reader.next();
// 统计 a 左边 p 的个数
int p = 0;
// 统计 a 右边 t 的个数
int t = 0;
// 统计第一个 a 左边的 p 的个数
for (int i = str.indexOf('P'); i != -1 && i < str.indexOf('A'); i = str.indexOf('P', i + 1))
p++;
// 统计第一个 a 右边的 t 的个数
for (int i = str.indexOf('T', str.indexOf('A')); i != -1; i = str.indexOf('T', i + 1))
t++;
// 统计第一个 a 对应的 PAT 组合的个数
int sum = p * t;
// 逐个统计除第一个 a 对应的 pat 组合的个数,并且累加并求余
for (int i = str.indexOf("A", str.indexOf("A") + 1); i != -1; i = str.indexOf("A", i + 1)) {
for (int j = str.lastIndexOf("A", i - 1) + 1; j < i; j++) {
if (j == -1) break;
char c = str.charAt(j);
if (c == 'P') p++;
if (c == 'T') t--;
}
sum += p * t;
sum %= 1000000007;
}
System.out.println(sum);
}
}
/** Class for buffered reading int and double values */
class Reader {
static BufferedReader reader;
static StringTokenizer tokenizer;
/** call this method to initialize reader for InputStream */
static void init(InputStream input) {
reader = new BufferedReader(new InputStreamReader(input));
tokenizer = new StringTokenizer("");
}
/** get next word */
static String next() throws IOException {
while (!tokenizer.hasMoreTokens())
//TODO add check for eof if necessary
tokenizer = new StringTokenizer(reader.readLine());
return tokenizer.nextToken();
}
}
思路二
扫描整个字符串,当遇到 P 的时候 P 计数器加一,如果遇到一个 A,此时计算 PA 的组合的个数,将 PA 计数器加上当前新多出来的 PA 组合的个数,同理,遇到 T 时,此时计算 PAT 的组合,将 PA 看作一个整体,T 看作一个整体,进行同计算 PA 相同的运算。最后得出 PAT 组合的个数。
import java.io.*;
import java.util.*;
public class Main {
static int DIVISOR = 1000000007;
public static void main(String[] args) throws IOException {
Reader.init(System.in);
String str = Reader.next();
// 分别为 p 的个数,pa 组合的个数,pat 组合的个数
int p = 0, pa = 0, pat = 0;
for (int i = 0; i < str.length(); i++) {
char c = str.charAt(i);
switch (c) {
case 'P':
p++;
break;
case 'A':
pa = (pa + p) % DIVISOR;
break;
case 'T':
pat = (pat + pa) % DIVISOR;
break;
}
}
System.out.println(pat);
}
}
/** Class for buffered reading int and double values */
class Reader {
static BufferedReader reader;
static StringTokenizer tokenizer;
/** call this method to initialize reader for InputStream */
static void init(InputStream input) {
reader = new BufferedReader(new InputStreamReader(input));
tokenizer = new StringTokenizer("");
}
/** get next word */
static String next() throws IOException {
while (!tokenizer.hasMoreTokens())
//TODO add check for eof if necessary
tokenizer = new StringTokenizer(reader.readLine());
return tokenizer.nextToken();
}
}