PAT (Basic Level) Practice (中文)1081 检查密码 (15 分)(Java实现)

52 篇文章 0 订阅
51 篇文章 0 订阅

题目描述

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.;
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.;
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

代码示例(Java实现)

/**
 * 这题看起来很简单,实际上有坑的,由于题目中描述只能由 字母,数字和小数点,
 * 所以 空格也属于非法字符,但是 Scanner 的 next 方法会截断空格,
 * 造成不能通过全部的点
 * 
 * 还有一点,我很奇怪,如果密码全部是小数点,例如 "..................." 这个
 * 按照题目的描述,是没有正确的答案的
 */
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int counts = Integer.parseInt(cin.nextLine());
        for (int i = 0; i < counts; i++) {
            String password = cin.nextLine();
            if (password.length() < 6) {
                System.out.println("Your password is tai duan le.");
            } else {
                // 标记字母存在
                boolean aFlag = false;
                // 表示数字存在
                boolean oneFlag = false;
                int j = 0;
                for (; j < password.length(); j++) {
                    char c = password.charAt(j);
                    if (c >= 'a' && c <= 'z' || c >= 'A' && c <= 'Z') {
                        aFlag = true;
                    } else if (c >= '0' && c <= '9') {
                        oneFlag = true;
                    } else if (c == '.') {
                    } else {
                        System.out.println("Your password is tai luan le.");
                        break;
                    }
                }
                if (j == password.length()) {
                    if (aFlag && oneFlag) {
                        System.out.println("Your password is wan mei.");
                    } else if (aFlag) {
                        System.out.println("Your password needs shu zi.");
                    } else if (oneFlag) {
                        System.out.println("Your password needs zi mu.");
                    } else {
                    	// 这个地方存在异或
                        // System.out.println("Your password is wan mei.");
                        // System.out.println("Your password is tai duan le.");
                        // System.out.println("Your password needs shu zi.");
                        // System.out.println("Your password is tai luan le.");
                        // System.out.println("Your password needs zi mu.");
                    }
                }
            }
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值