题目描述:
给定一段一段的绳子,你需要把它们串成一条绳。每次串连的时候,是把两段绳子对折,再如下图所示套接在一起。这样得到的绳子又被当成是另一段绳子,可以再次对折去跟另一段绳子串连。每次串连后,原来两段绳子的长度就会减半。
参考图片(来源:https://pintia.cn/problem-sets/994805260223102976/problems/994805264706813952)
给定 N 段绳子的长度,你需要找出它们能串成的绳子的最大长度。
输入格式:
每个输入包含 1 个测试用例。每个测试用例第 1 行给出正整数 N ( 2 ≤ N ≤ 10 4 ) N(2≤N≤10^4) N(2≤N≤104);第 2 行给出 N N N 个正整数,即原始绳段的长度,数字间以空格分隔。所有整数都不超过 10 4 10^4 104 。
输出格式:
在一行中输出能够串成的绳子的最大长度。结果向下取整,即取为不超过最大长度的最近整数。
输入样例:
8
10 15 12 3 4 13 1 15
输出样例:
14
代码示例(Java)
import java.util.*;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStream;
import java.io.InputStreamReader;
/**
* @author snowflake
* @create-date 2019-07-17 14:23
*/
public class Main {
public static void main(String[] args) throws IOException {
Reader.init(System.in);
int count = Reader.nextInt();
// 定义一个优先队列,存储每条绳子的长度
// 使用这个数据结构,可以比线性的快
PriorityQueue<Double> ropes = new PriorityQueue<>(count);
for (int i = 0; i < count; i++) {
ropes.add(Reader.nextDouble());
}
while (ropes.size() > 1) {
double min1 = ropes.poll();
double min2 = ropes.poll();
double temp = (min1 + min2) / 2.0;
ropes.offer(temp);
}
System.out.println((int) Math.floor(ropes.peek()));
}
}
class Reader {
static BufferedReader reader;
static StringTokenizer tokenizer;
/** call this method to initialize reader for InputStream */
static void init(InputStream input) {
reader = new BufferedReader(new InputStreamReader(input));
tokenizer = new StringTokenizer("");
}
/** get next word */
static String next() throws IOException {
while (!tokenizer.hasMoreTokens())
//TODO add check for eof if necessary
tokenizer = new StringTokenizer(reader.readLine());
return tokenizer.nextToken();
}
static int nextInt() throws IOException {
return Integer.parseInt(next());
}
static double nextDouble() throws IOException {
return Double.parseDouble(next());
}
}