A Mathematical Curiosity
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 42503 Accepted Submission(s): 13665
Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input
1 10 1 20 3 30 4 0 0
Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
Source
Recommend
JGShining | We have carefully selected several similar problems for you: 1008 1016 1005 1021 1012
这个题目,读懂题目意思不难,但是,坑的是题目的输出格式,为此,PE的好几次,呜呼!题目 a,b的范围很小,所以我们立马决定得用一个二重循坏,话不多说,看代码。
AC代码如下:
#include<stdio.h>
int main(){
int t;
scanf("%d",&t);
while(t--){
int n,m,k=1;
while(scanf("%d%d",&n,&m)!=EOF&&(n!=0||m!=0)){
int count=0;
for(int i=1;i<n;i++){
for(int j=i+1;j<n;j++){
double x=(i*i+j*j+m)*1.0/(i*j);
if(x==(int)x)//判断是否为整数
count++;
}
}
printf("Case %d: %d\n",k++,count);
}
if(t)//格式空行,很重要
printf("\n");
}
return 0;
}