4.6 PAT 甲级 1071 Speech Patterns

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5
#include<iostream>
#include<unordered_map>
using namespace std;

//把大写字母变小写
char lower(char c)
{
    if(c>='A'&&c<='Z')
        return c+32;
    return c;
}

//判断是否是单词的组成字符
bool is_word(char c)
{
    if(c>='0'&&c<='9')
        return true;
    else if(c>='a'&&c<='z')
        return true;
    else if(c>='A'&&c<='Z')
        return true;
    else
        return false;
}

int main()
{
    string s;
    getline(cin,s);

    //用双指针所有单词放入map容器中,并将大写变成小写
    unordered_map<string,int>hash;
    for(int i=0;i<s.length();i++)
    {
        if(is_word(s[i]))
        {
            string word;
            int j=i;
            while(j<s.length()&&is_word(s[j]))
            {
                word+=lower(s[j]);
                j++;
            }
            hash[word]++;
            i=j;
        }
    }

    //找出出现次数最多的那个单词
    int cnt=-1;
    string maxword;
    for(auto x:hash)
        if((x.second==cnt&&maxword>x.first)||x.second>cnt)
        {
            cnt=x.second;
            maxword=x.first;
        }
    cout<<maxword<<" "<<cnt<<endl;

    return 0;
}

(思路来源于y总上的辅导课)

题意就是输入一行字符串,统计其中出现最多的单词(连续的数字和字母组成一个单词,不区分大小写)。

首先输入一行字符。然后用双指针的办法(就是一个指针指向头,另一个指针向后走,直到遇到不是组成单词的合法字符的字符)遍历这个字符串,取出其中的每一个单词,用unordered_map容器来装单词,并进行单词的数据统计。最后根据出现的次数来排序,输出出现次数最多的单词以及其出现次数,如果出现次数相等,就输出单词字典序小的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值