8.20 PAT 甲级 1148 Werewolf - Simple Version

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

这题不用什么技巧,就是用枚举。因为输出的是两个狼人的编号且要求其字典序最小,所以从小到大依次枚举,假设两个人是狼。假设i,j为狼人,如果i,j一人说的真话,一人说的假话,且所有人里只有两人说假话,则结果成立。

#include<iostream>
#include<algorithm>

using namespace std;

const int N = 110;
int n, q[N], temp[N];

//假设b,c是狼人,如果返回1则a说的假话,返回0则a说的真话
int are_they_liars(int a, int b, int c)
{
    int t = q[a];
    if(t > 0)
    {
        if(t == b || t == c) return 1;
        return 0;
    }
    
    t = -t;
    if(t == b || t == c)    return 0;
    return 1;
    
}

int main()
{
    cin >> n;
    
    for(int i = 1; i <= n; i ++ )    cin >> q[i];
    
    for(int i = 1; i < n; i ++ )
    {
        for(int j = i + 1; j <= n; j ++ )
        {
            int s = are_they_liars(i, i, j) + are_they_liars(j, i, j);
            if(s != 1)  continue;
            
            s = 0;
            for(int k = 1; k <= n; k ++ )
                s += are_they_liars(k, i, j);
            if(s != 2)  continue;
            
            cout << i << ' ' << j << endl;
            return 0;
        }
    }
    
    cout << "No Solution" << endl;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值