9.2 PAT 甲级 1095 Cars on Campus

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09
//按照进入学校的时间进行排序,查询一个时间的时候就判断在这个时间点之前进入学校的车有没有出校门
#include<iostream>
#include<algorithm>
#include<unordered_map>
#include<vector>

using namespace std;

const int N = 10010;
struct state
{
    string in_or_out;
    int totaltime;
    
    bool operator< (const state &s)const
    {
        return totaltime < s.totaltime;
    }
};

//存储输出结果
struct otpt
{
    string id;
    int totaltime;
    
};

bool cmp(otpt o1, otpt o2)
{
    if(o1.totaltime != o2.totaltime)
        return o1.totaltime > o2.totaltime;
    else
        return o1.id < o2.id;
}

//输入小时分钟秒数,计算距离00:00:00的秒数
int caltime(int hour, int minute, int second)
{
    int res = 0;
    res = hour * 3600 + minute * 60 + second;
    return res;
}

unordered_map<string, vector<state>>cars;
int n, k;

int main()
{
    scanf("%d%d", &n, &k);
    for(int i = 0; i < n; i ++ )
    {
        char id[10], st[10];
        int hour, minute, second;
        scanf("%s %d:%d:%d %s", id, &hour, &minute, &second, st);
        int t = caltime(hour, minute, second);
        cars[id].push_back({st, t});
    }
    
    vector<otpt>res1;
    vector<state>res2;
    for(auto& car : cars)
    {
        auto& s = car.second;
        sort(s.begin(), s.end());
        int times = 0;
        
        for(int i = 0; i < (int)s.size(); i ++ )
        {
            
            if (s[i].in_or_out == "in")
            {
                if((i + 1) < (int)s.size() && s[i + 1].in_or_out == "out")
                {
                    times += (s[i + 1].totaltime - s[i].totaltime);
                    res2.push_back(s[i]);
                    res2.push_back(s[i + 1]);
                    i ++;
                }
            }
        }
        res1.push_back({car.first, times});
        //cout << car.first << endl;
    }
    
    sort(res1.begin(), res1.end(), cmp);
    sort(res2.begin(), res2.end());
    
    int m = 0, sum = 0;
    for(int i = 0; i < k; i ++ )
    {
        int hour, minute, second;
        scanf("%d:%d:%d", &hour, &minute, &second);
        int t = caltime(hour, minute, second);
        
        while(m < (int)res2.size() && res2[m].totaltime <= t)
        {
            if(res2[m].in_or_out == "in")
                sum ++;
            else
                sum --;
            m ++;
        }
        
        printf("%d\n", sum);
    }
    
    int j = 0, time = res1[j].totaltime;
    
    while(res1[j].totaltime == time)
    {
        cout << res1[j].id << ' ';
        j ++;
    }
    printf("%02d:%02d:%02d\n", time / 3600, time / 60 % 60, time % 60);
    
}

果然没有最麻烦。。只有更麻烦。。好好的可以人工计数为啥一定要写程序来记呢。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值