9.28 PAT 甲级 1085 Perfect Sequence

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8
#include<iostream>
#include<algorithm>

using namespace std;

const int N = 100010;

int p, n;
int t[N];

int main()
{
    cin >> n >> p;
    for(int i = 0; i < n; i ++)
        scanf("%d", &t[i]);
        
    sort(t, t + n);
    
    int res = 0;
    //i为最小值的指针,j为最大值的指针
    for(int i = 0, j = 0; j < n; i ++)
    {
        while(t[j] <= (long long)t[i] * p && j < n)   j ++;
        int l = j - i;
        if(res < l) res = l;
    }
    
    cout << res << endl;
    
    return 0;
}

经历了无数次数组越界。。劝大家在while循环那里谨慎出行。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值