1066 Root of AVL Tree (25 分) (模板)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 AVL树:任何节点的两个子子树的高度最多相差一个

做题思路:

  • insert表示插入建树的过程,如果root为空,直接新建结点插入
  • 如果当前要插入的值<root->val,则插入root的左子树;反之则插入root的右子树
  • 如果插入后getHeight左右子树高度差==2,若<,<则右转;<,>先向左旋后向右旋;>,>向左旋;>,<先向右旋后向左旋
  • rotateLeft表示向左旋,rotateRight表示向右旋
  • rotateLeftRight表示先向左旋后向右旋,rotateRightLeft表示先向右旋后向左旋
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct node {
	int val;
	node *left,*right;
};
int getHeight(node* r){
	if(r==NULL) return 0;
	return max(getHeight(r->left),getHeight(r->right))+1;
}
node* rotateLeft(node* r){
	node* t=r->right;
	r->right=t->left;
	t->left=r;
	return t;
}
node* rotateRight(node* r){
	node* t=r->left;
	r->left=t->right;
	t->right=r;
	return t;
}
node* rotateLeftRight(node* r){
	r->left=rotateLeft(r->left);
	r=rotateRight(r);
	return r;
}
node* rotateRightLeft(node* r){
	r->right=rotateRight(r->right);
	r=rotateLeft(r);
	return r;
}
node* insert(node* r,int x){
	if(r==NULL){
		node* r=(struct node*)malloc(sizeof(struct node));
		r->val=x;
		r->left=r->right=NULL;
		return r;
	}
	if(x<r->val){
		r->left=insert(r->left,x);
		if(getHeight(r->left)-getHeight(r->right)==2) 
			r=(x<r->left->val)?rotateRight(r):rotateLeftRight(r);
	}
	else{
		r->right=insert(r->right,x);
		if(getHeight(r->right)-getHeight(r->left)==2) 
			r=(x>r->right->val)?rotateLeft(r):rotateRightLeft(r);
	}
	return r;
}
int main() {
	int n,x;
	cin>>n;
	node* r=NULL;
	for(int i=0; i<n; i++) {
		cin>>x;
		r=insert(r,x);
	}
	cout<<r->val<<endl;
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值