Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.
First the playing order is randomly decided for NPN_PNP programmers. Then every NGN_GNG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGN_GNG winners are then grouped in the next match until a final winner is determined.
For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: NPN_PNP and NGN_GNG (≤1000\le 1000≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NGN_GNG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NPN_PNP distinct non-negative numbers WiW_iWi (i=0,⋯,NP−1i=0,\cdots ,N_P -1i=0,⋯,NP−1) where each WiW_iWi is the weight of the iii-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP−10,\cdots ,N_P -10,⋯,NP−1 (assume that the programmers are numbered from 0 to NP−1N_P -1NP−1). All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the final ranks in a line. The iii-th number is the rank of the iii-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 3 25 18 0 46 37 3 19 22 57 56 10 6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
题意:n个老鼠,每组最多g个,给出分组之后的序列,要求每组选出最大的,每组最大的老鼠再组成序列、分组、选最大;踢掉的老鼠排名一致,选出的老鼠名次靠前一位。最后按照输入的顺序输出每只老鼠的排名。
思路:
- 每个老鼠拥有两个id,输入id(日后输出要用)、分组id(存入数组比拼要用),rank,和 weight
- 每个老鼠的排名是当前组别数+1,组别数=队列size/g并向上取整
- 每次取一个组别,maxnode维护最大节点用于下一轮入队列;maxn用于维护本组最大体重(for:0----size,cnt%g==0||i==size为当前组最后一个,cnt、maxn初始化,maxnode入队列)
- 每次取后先判断是否最后一个,若是排名置为1输出。
#include<bits/stdc++.h>
using namespace std;
int w[1005];
struct node{
int weight;
int or_id;
int id;
int rank;
}mouse[1005];
bool cmp(node a,node b){
return a.or_id<b.or_id;
}
queue<node> q;
int main(){
int n,g,num;
scanf("%d%d",&n,&g);
for(int i=0;i<n;i++) scanf("%d",&w[i]);
for(int i=0;i<n;i++){
scanf("%d",&num);
mouse[i].weight=w[num];
mouse[i].id=i;
mouse[i].or_id=num;
q.push(mouse[i]);
}
while(!q.empty()){
int size=q.size();
if(size==1){
node tmp=q.front();
mouse[tmp.id].rank=1;
break;
}
int group=size/g;
if(size%g) group++;
node maxnode;
int maxn=-1,cnt=0;
for(int i=0;i<size;i++){
node tmp=q.front();
mouse[tmp.id].rank=group+1;
q.pop();
cnt++;
if(tmp.weight>maxn){
maxn=tmp.weight;
maxnode=tmp;
}
if(cnt==g||i==size-1){
cnt=0;
maxn=-1;
q.push(maxnode);
}
}
}
//sort(mouse,mouse+n,cmp);
for(int i=0;i<n;i++){
if(i) cout<<" ";
cout<<mouse[i].rank;
}
return 0;
}