1135 Is It A Red-Black Tree (30 分)()

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

题意:判断是否为红黑树。

红黑树特征:

  • 根节点必为黑色
  • 一个红色节点的两个孩子必为黑色
  • 任意结点到根节点经过的黑点数相同

思路:

  • 建树
  • 判断根节点是否为黑色
  • 递归判断是否红色节点的叶子节点为黑色 judge1
  • 递归判断左右子树的黑点的个数是否相同 judge2

空即返回true

  • judge1(若当前结点为红色,若其左子树存在且其颜色不为黑色返回false,同理右子树;递归检查左右子树)
  • judge2(得到当前左子树和右子树中含有黑点的高度getNum(),若不相等返回false,递归检查)
  • getNum(root)得到当前以root为根的树中左子树和右子树含黑点的数量,若当前点也是黑点,返回max(l,r)+1,否则返回max(r,l)
#include<bits/stdc++.h>
using namespace std;
int a[35];
struct node{
	node *left,*right;
	int val;
};
node *build(node *root,int val){
	if(root==NULL){
		root=new node();
		root->val=val;
		root->left=root->right=NULL;
	}
	else if(abs(val)<=abs(root->val)) root->left=build(root->left,val);//
	else root->right=build(root->right,val);
	return root;
}
bool judge1(node *root){
	if(root==NULL) return true;
	if(root->val<0){
		if(root->left!=NULL&&root->left->val<0) return false;
		if(root->right!=NULL&&root->right->val<0) return false;//
	}
	return judge1(root->left)&&judge1(root->right);
}
int getNum(node *root){
	if(root==NULL) return 0;
	int l=getNum(root->left);
	int r=getNum(root->right);
	return root->val>0? max(l,r)+1:max(l,r);
}
bool judge2(node *root){
	if(root==NULL) return true;
	int l=getNum(root->left);
	int r=getNum(root->right);
	if(l!=r) return false;
	return judge2(root->left)&&judge2(root->right);
}
int main(){
	int n,m;
	scanf("%d",&m);
	while(m--){
		scanf("%d",&n);
		node *root=NULL;
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);	
			root=build(root,a[i]);
		}
		if(a[0]<0||judge1(root)==false||judge2(root)==false) cout<<"No\n";
		else cout<<"Yes\n";
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值