1014 Waiting in Line (30 分)

Suppose a bank has NNN windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with MMM customers. Hence when all the NNN lines are full, all the customers after (and including) the (NM+1)(NM+1)(NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • CustomeriCustomer_iCustomer​i​​ will take TiT_iT​i​​ minutes to have his/her transaction processed.
  • The first NNN customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1customer_1customer​1​​ is served at window1window_1window​1​​ while customer2customer_2customer​2​​ is served at window2window_2window​2​​. Customer3Customer_3Customer​3​​ will wait in front of window1window_1window​1​​ and customer4customer_4customer​4​​ will wait in front of window2window_2window​2​​. Customer5Customer_5Customer​5​​ will wait behind the yellow line.

At 08:01, customer1customer_1customer​1​​ is done and customer5customer_5customer​5​​ enters the line in front of window1window_1window​1​​ since that line seems shorter now. Customer2Customer_2Customer​2​​ will leave at 08:02, customer4customer_4customer​4​​ at 08:06, customer3customer_3customer​3​​ at 08:07, and finally customer5customer_5customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: NNN (≤20\le 20≤20, number of windows), MMM (≤10\le 10≤10, the maximum capacity of each line inside the yellow line), KKK (≤1000\le 1000≤1000, number of customers), and QQQ (≤1000\le 1000≤1000, number of customer queries).

The next line contains KKK positive integers, which are the processing time of the KKK customers.

The last line contains QQQ positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to KKK.

Output Specification:

For each of the QQQ customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

 题意:n个窗口,每个窗口可以排队m人。有k位用户需要服务,给出了每位用户需要的分钟数,所有客户在8点开始服务,如果有窗口还没排满就入队,否则就在黄线外等候。如果有某一列有一个用户走了服务完毕了,黄线外的人就进来一个。如果同时就选窗口数小的。求q个人的服务结束时间。如果一个客户在17:00以及以后还没有开始服务(此处不是结束服务是开始17:00)就不再服务输出sorry;如果这个服务已经开始了,无论时间多长都要等他服务完毕。

分析:设立结构体,里面包含poptime为队首的人出队(结束)的时间(让黄线外的人知道哪一个队列先空出人来,poptime最小的窗口先有人服务完毕,和endtime为队尾的人结束的时间(决定了下一个人是否能被服务,如果前一个人服务结束时间超过17:00,自己当前入队的人就是sorry,还有一个queue表示所有当前该窗口的排队队列。

排的下(前m*n个人):所有人依次到窗口前面排队。

排不下(m*n之后的人):当前人选择poptime最短的入队,让队伍的第一个人出列,如果前面一个人导致的endtime超过17点就标记自己的sorry为true。计算时间的时候按照分钟计算,最后再考虑08点开始和转换为小时分钟的形式会比较简便。

#include<bits/stdc++.h>
using namespace std;
struct node {
	int poptime,endtime;
	queue<int> q;
};
int main() {
	int n,m,k,q,x,id=1;
	scanf("%d%d%d%d",&n,&m,&k,&q);
	vector<int> time(k+1),result(k+1);
	vector<bool> sorry(k+1,false);
	vector<node> windows(n+1);

	for(int i=1; i<=k; i++)
		scanf("%d",&time[i]);
	for(int i=1; i<=m; i++) {
		for(int j=1; j<=n; j++) {
			if(id<=k) {
				windows[j].q.push(time[id]);
				if(windows[j].endtime>=540) sorry[id]=true;
				windows[j].endtime+=time[id];
				result[id]=windows[j].endtime;
				if(i==1) windows[j].poptime=time[id];
				id++;
			}
		}
	}
	while(id<=k) {
		int tmpwindow=1,tmpendtime=windows[1].poptime;
		for(int i=2; i<=n; i++) {
			if(tmpendtime>windows[i].poptime) {
				tmpwindow=i;
				tmpendtime=windows[i].poptime;
			}
		}
		windows[tmpwindow].q.pop();
		windows[tmpwindow].q.push(time[id]);
		windows[tmpwindow].poptime+=windows[tmpwindow].q.front();
		if(windows[tmpwindow].endtime>=540) sorry[id]=true;
		windows[tmpwindow].endtime+=time[id];
		result[id]=windows[tmpwindow].endtime;
		id++;
	}
	for(int i=1; i<=q; i++) {
		scanf("%d",&x);
		if(sorry[x]==true) printf("Sorry\n");
		else printf("%02d:%02d\n",(result[x]+480)/60,(result[x]+480)%60);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C语言是一种广泛使用的编程语言,它具有高效、灵活、可移植性强等特点,被广泛应用于操作系统、嵌入式系统、数据库、编译器等领域的开发。C语言的基本语法包括变量、数据类型、运算符、控制结构(如if语句、循环语句等)、函数、指针等。在编写C程序时,需要注意变量的声明和定义、指针的使用、内存的分配与释放等问题。C语言中常用的数据结构包括: 1. 数组:一种存储同类型数据的结构,可以进行索引访问和修改。 2. 链表:一种存储不同类型数据的结构,每个节点包含数据和指向下一个节点的指针。 3. 栈:一种后进先出(LIFO)的数据结构,可以通过压入(push)和弹出(pop)操作进行数据的存储和取出。 4. 队列:一种先进先出(FIFO)的数据结构,可以通过入队(enqueue)和出队(dequeue)操作进行数据的存储和取出。 5. 树:一种存储具有父子关系的数据结构,可以通过中序遍历、前序遍历和后序遍历等方式进行数据的访问和修改。 6. 图:一种存储具有节点和边关系的数据结构,可以通过广度优先搜索、深度优先搜索等方式进行数据的访问和修改。 这些数据结构在C语言中都有相应的实现方式,可以应用于各种不同的场景。C语言中的各种数据结构都有其优缺点,下面列举一些常见的数据结构的优缺点: 数组: 优点:访问和修改元素的速度非常快,适用于需要频繁读取和修改数据的场合。 缺点:数组的长度是固定的,不适合存储大小不固定的动态数据,另外数组在内存中是连续分配的,当数组较大时可能会导致内存碎片化。 链表: 优点:可以方便地插入和删除元素,适用于需要频繁插入和删除数据的场合。 缺点:访问和修改元素的速度相对较慢,因为需要遍历链表找到指定的节点。 栈: 优点:后进先出(LIFO)的特性使得栈在处理递归和括号匹配等问题时非常方便。 缺点:栈的空间有限,当数据量较大时可能会导致栈溢出。 队列: 优点:先进先出(FIFO)的特性使得
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值