1014 Waiting in Line (30 分)

Suppose a bank has NNN windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with MMM customers. Hence when all the NNN lines are full, all the customers after (and including) the (NM+1)(NM+1)(NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • CustomeriCustomer_iCustomer​i​​ will take TiT_iT​i​​ minutes to have his/her transaction processed.
  • The first NNN customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1customer_1customer​1​​ is served at window1window_1window​1​​ while customer2customer_2customer​2​​ is served at window2window_2window​2​​. Customer3Customer_3Customer​3​​ will wait in front of window1window_1window​1​​ and customer4customer_4customer​4​​ will wait in front of window2window_2window​2​​. Customer5Customer_5Customer​5​​ will wait behind the yellow line.

At 08:01, customer1customer_1customer​1​​ is done and customer5customer_5customer​5​​ enters the line in front of window1window_1window​1​​ since that line seems shorter now. Customer2Customer_2Customer​2​​ will leave at 08:02, customer4customer_4customer​4​​ at 08:06, customer3customer_3customer​3​​ at 08:07, and finally customer5customer_5customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: NNN (≤20\le 20≤20, number of windows), MMM (≤10\le 10≤10, the maximum capacity of each line inside the yellow line), KKK (≤1000\le 1000≤1000, number of customers), and QQQ (≤1000\le 1000≤1000, number of customer queries).

The next line contains KKK positive integers, which are the processing time of the KKK customers.

The last line contains QQQ positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to KKK.

Output Specification:

For each of the QQQ customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

 题意:n个窗口,每个窗口可以排队m人。有k位用户需要服务,给出了每位用户需要的分钟数,所有客户在8点开始服务,如果有窗口还没排满就入队,否则就在黄线外等候。如果有某一列有一个用户走了服务完毕了,黄线外的人就进来一个。如果同时就选窗口数小的。求q个人的服务结束时间。如果一个客户在17:00以及以后还没有开始服务(此处不是结束服务是开始17:00)就不再服务输出sorry;如果这个服务已经开始了,无论时间多长都要等他服务完毕。

分析:设立结构体,里面包含poptime为队首的人出队(结束)的时间(让黄线外的人知道哪一个队列先空出人来,poptime最小的窗口先有人服务完毕,和endtime为队尾的人结束的时间(决定了下一个人是否能被服务,如果前一个人服务结束时间超过17:00,自己当前入队的人就是sorry,还有一个queue表示所有当前该窗口的排队队列。

排的下(前m*n个人):所有人依次到窗口前面排队。

排不下(m*n之后的人):当前人选择poptime最短的入队,让队伍的第一个人出列,如果前面一个人导致的endtime超过17点就标记自己的sorry为true。计算时间的时候按照分钟计算,最后再考虑08点开始和转换为小时分钟的形式会比较简便。

#include<bits/stdc++.h>
using namespace std;
struct node {
	int poptime,endtime;
	queue<int> q;
};
int main() {
	int n,m,k,q,x,id=1;
	scanf("%d%d%d%d",&n,&m,&k,&q);
	vector<int> time(k+1),result(k+1);
	vector<bool> sorry(k+1,false);
	vector<node> windows(n+1);

	for(int i=1; i<=k; i++)
		scanf("%d",&time[i]);
	for(int i=1; i<=m; i++) {
		for(int j=1; j<=n; j++) {
			if(id<=k) {
				windows[j].q.push(time[id]);
				if(windows[j].endtime>=540) sorry[id]=true;
				windows[j].endtime+=time[id];
				result[id]=windows[j].endtime;
				if(i==1) windows[j].poptime=time[id];
				id++;
			}
		}
	}
	while(id<=k) {
		int tmpwindow=1,tmpendtime=windows[1].poptime;
		for(int i=2; i<=n; i++) {
			if(tmpendtime>windows[i].poptime) {
				tmpwindow=i;
				tmpendtime=windows[i].poptime;
			}
		}
		windows[tmpwindow].q.pop();
		windows[tmpwindow].q.push(time[id]);
		windows[tmpwindow].poptime+=windows[tmpwindow].q.front();
		if(windows[tmpwindow].endtime>=540) sorry[id]=true;
		windows[tmpwindow].endtime+=time[id];
		result[id]=windows[tmpwindow].endtime;
		id++;
	}
	for(int i=1; i<=q; i++) {
		scanf("%d",&x);
		if(sorry[x]==true) printf("Sorry\n");
		else printf("%02d:%02d\n",(result[x]+480)/60,(result[x]+480)%60);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值