HDU - 1851 A Simple Game

Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M 1 stones, the 2nd pile has M 2 stones, ... and the n-th pile contain M n stones. Agrael and Animal take turns to move and in each move each of the players can take at most L 1 stones from the 1st pile or take at most L 2 stones from the 2nd pile or ... or take L n stones from the n-th pile. The player who takes the last stone wins.

After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?

The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.

Input

The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers M i and L i (20 ≥ M i > 0, 20 ≥ L i > 0).

Output

Your program output one line per case, if Agrael can win the game print "Yes", else print "No".

Sample Input

2
1
5 4
2
1 1
2 2

Sample Output

Yes
No

题意:n堆石子,分别有M1,M2,·······,Mn个石子,各堆分别最多取L1,L2,·····Ln个石头,两个人分别取,一次只能从一堆中取,取走最后一个石子的人获胜。后选的人获胜输出Yes,否则输出No,

第一行一个数字表示数据有多少组,每组测试数据第一行是一个整数n,表示有n行,然后n行分别是两个整数Mi,Li. 表示第i堆有Mi个石子,一次最多去Li个石子。

 

若只有一堆,sum%(take+1)==0则后手胜,若类似堆出现偶数次则后手胜 0^0=0

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
int main(){
	int t,heap,sum,take;
	int res;
	cin>>t;
	while(t--){
		res=0;//与零异或后为本身故初始化为0
		cin>>heap;
		for(int i=0;i<heap;i++){
			cin>>sum>>take;
			res^=sum%(take+1);
		}
		if(!res) cout<<"Yes\n";//异或为零,后手获胜
		else cout<<"No\n"; 
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值