【HDU4405】Aeroplane chess(概率dp)

题目链接

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6278    Accepted Submission(s): 3901


 

Problem Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

 

 

Input

There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.

 

 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

 

 

Sample Input

 

2 0 8 3 2 4 4 5 7 8 0 0

 

 

Sample Output

 

1.1667 2.3441

 

【题意】

在编号为0-n的格子中下飞行棋?!起点为0终点为n,买掷一次骰子可以前进相应步数,有的位置可以直接飞到另一个位置,计算走到n点的掷骰子的期望次数。

【解题思路】

期望....给跪qaq感觉是世界上最恶心的东西之一,但是再恶心还是得做不是吗。

设dp[i]为到i点的期望次数,首先要清楚在n这个点因为已经到达终点,所以不用再掷骰子了,期望是0,那么dp[n]=0,既然已经知道最后一个点的期望,那么就可以从前往后推,问题就转换成了求dp[0]的期望。

因为i这个状态要转换成下一个状态可以掷骰子1-6,每掷一次筛子有1/6的可能,所以最终期望就是每次的步数*概率之和。别忘了最后得加1,因为从当前状态转换成下一个状态需要掷一次筛子。

【代码】

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int to[maxn];
double dp[maxn];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m) && n || m)
    {
        memset(dp,0,sizeof(dp));
        memset(to,0,sizeof(to));
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            to[x]=y;
        }
        for(int i=n-1;i>=0;i--)
        {
            if(to[i])
            {
                dp[i]=dp[to[i]];
                continue;
            }
            for(int j=i+1;j<=i+6;j++)
                dp[i]+=dp[j]/6;
            dp[i]+=1;
        }
        printf("%.4f\n",dp[0]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值